Skip to content
Laskyr

Plugins · lead-form-builder · data as of 2026-11-04

Is Lead Form Builder & Contact Form safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.6)

As of 2026-11-04. 7 issues are on record for older versions; version 2.0.3 or newer fixes all of them that state a fix.

Latest version
2.2.6
Last updated
2026-09-19
Active installs
8,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4

Drag & Drop Contact Form Builder for WordPress to create contact, lead generation, Cloudflare Turnstile CAPTCHA Support. — by ThemeHunk

What to do

  1. Update to the latest version (2.2.6). Anything older than 2.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get lead-form-builder --field=version shows what you run; wp plugin update lead-form-builder updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2023-25969 · published 2026-06-11

Missing authorization check in Lead Form Builder & Contact Form (1.8.4 and older)

Affected
1.8.4 and older
Fixed in
1.8.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in ThemeHunk Contact Form & Lead Form Elementor Builder allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Contact Form & Lead Form Elementor Builder: from n/a through 1.8.4.

NVD CVE-2023-25969Patchstack advisory

high 7.1 CVE-2026-32532 · published 2026-03-25

Stored cross-site scripting (XSS) in Lead Form Builder & Contact Form (2.0.1 and older)

Affected
2.0.1 and older
Fixed in
2.0.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ThemeHunk Contact Form & Lead Form Elementor Builder lead-form-builder allows Stored XSS.This issue affects Contact Form & Lead Form Elementor Builder: from n/a through <= 2.0.1.

NVD CVE-2026-32532Patchstack advisory

high 7.2 CVE-2026-1454 · published 2026-03-11

Stored cross-site scripting (XSS) in Lead Form Builder & Contact Form (2.0.1 and older)

Affected
2.0.1 and older
Fixed in
2.0.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Responsive Contact Form Builder & Lead Generation Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 2.0.1 via form field submissions. This is due to insufficient input sanitization in the lfb_lead_sanitize() function which omits certain field types from its sanitization whitelist, combined with an overly permissive wp_kses() filter at output time that allows onclick attributes on anchor tags. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an administrator views the lead entries in the WordPress dashboard.

NVD CVE-2026-1454Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-68046 · published 2026-01-22

Information disclosure in Lead Form Builder & Contact Form (2.0.1 and older)

Affected
2.0.1 and older
Fixed in
2.0.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in ThemeHunk Contact Form & Lead Form Elementor Builder lead-form-builder allows Retrieve Embedded Sensitive Data.This issue affects Contact Form & Lead Form Elementor Builder: from n/a through <= 2.0.1.

NVD CVE-2025-68046Patchstack advisory

medium 5.4 CVE-2024-4261 · published 2024-05-22

Remote code execution in Lead Form Builder & Contact Form (1.9.1 and older)

Affected
1.9.1 and older
Fixed in
1.9.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Responsive Contact Form Builder & Lead Generation Plugin plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 1.9.1. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with subscriber-level access and above, to execute arbitrary shortcodes.

NVD CVE-2024-4261Wordfence advisoryPlugin source

medium 4.3 CVE-2024-1415 · published 2024-05-02

Cross-site request forgery (CSRF) in Lead Form Builder & Contact Form (1.8.9 and older)

Affected
1.8.9 and older
Fixed in
1.9.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Responsive Contact Form Builder & Lead Generation Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.8.9. This is due to missing or incorrect nonce validation on several functions. This makes it possible for unauthenticated attackers to invoke those functions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. These actions may result in form deletion, and lead signup as well as file upload.

NVD CVE-2024-1415Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2024-1416 · published 2024-05-02

Missing authorization check in Lead Form Builder & Contact Form (1.8.9 and older)

Affected
1.8.9 and older
Fixed in
1.9.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Responsive Contact Form Builder & Lead Generation Plugin plugin for WordPress is vulnerable to unauthorized access to functionality due to a missing capability check on several functions in all versions up to, and including, 1.8.9. This makes it possible for unauthenticated attackers to invoke those functions.

NVD CVE-2024-1416Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Lead Form Builder & Contact Form vulnerability status badge
<a href="https://laskyr.com/plugins/lead-form-builder"><img src="https://laskyr.com/plugins/lead-form-builder/badge.svg" alt="Lead Form Builder & Contact Form vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit