Skip to content
Laskyr

Plugins · lazy-blocks · data as of 2026-11-04

Is Custom Block Builder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.5.1)

As of 2026-11-04. 4 issues are on record for older versions; version 4.3.0 or newer fixes all of them that state a fix.

Latest version
4.5.1
Last updated
2026-10-26
Active installs
20,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.2 · PHP 8.3+

Easily create custom blocks and custom meta fields for Gutenberg without hard coding. — by nK

What to do

  1. Update to the latest version (4.5.1). Anything older than 4.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get lazy-blocks --field=version shows what you run; wp plugin update lazy-blocks updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

low 3.5 CVE-2026-8981 · published 2026-06-09

Cross-site scripting (XSS) in Custom Block Builder (older than 4.3.0)

Affected
older than 4.3.0
Fixed in
4.3.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Custom Block Builder WordPress plugin before 4.3.0 does not consistently check the unfiltered_html capability across all paths that write to its block template code fields, allowing administrators on multisite installations (or single-site installs with DISALLOW_UNFILTERED_HTML defined) to inject arbitrary JavaScript that executes for any visitor of pages embedding the affected block.

NVD CVE-2026-8981WPScan advisory

high 8.8 CVE-2026-1560 · published 2026-02-11

Remote code execution in Custom Block Builder (4.2.0 and older)

Affected
4.2.0 and older
Fixed in
4.2.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Custom Block Builder – Lazy Blocks plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.0 via multiple functions in the 'LazyBlocks_Blocks' class. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server.

NVD CVE-2026-1560Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-58258 · published 2025-09-22

Missing authorization check in Custom Block Builder (4.1.0 and older)

Affected
4.1.0 and older
Fixed in
4.1.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in nK Lazy Blocks lazy-blocks allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Lazy Blocks: from n/a through <= 4.1.0.

NVD CVE-2025-58258Patchstack advisory

high 7.1 CVE-2024-12878 · published 2025-02-26

Reflected cross-site scripting (XSS) in Custom Block Builder (older than 3.8.3)

Affected
older than 3.8.3
Fixed in
3.8.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Custom Block Builder WordPress plugin before 3.8.3 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.

NVD CVE-2024-12878WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Custom Block Builder vulnerability status badge
<a href="https://laskyr.com/plugins/lazy-blocks"><img src="https://laskyr.com/plugins/lazy-blocks/badge.svg" alt="Custom Block Builder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit