Skip to content
Laskyr

Plugins · kk-star-ratings · data as of 2026-11-04

Is kk Star Ratings safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.4.10.5)

As of 2026-11-04. 5 issues are on record for older versions; version 5.4.10.4 or newer fixes all of them that state a fix.

Latest version
5.4.10.5
Last updated
2026-08-20
Active installs
70,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

kk Star Ratings allows blog visitors to involve and interact more effectively with your website by rating posts. — by properfraction

What to do

  1. Update to the latest version (5.4.10.5). Anything older than 5.4.10.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get kk-star-ratings --field=version shows what you run; wp plugin update kk-star-ratings updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-3424 · published 2026-08-22

Remote code execution in kk Star Ratings (5.4.10.3 and older)

Affected
5.4.10.3 and older
Fixed in
5.4.10.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The kk Star Ratings – Rate Post & Collect User Feedbacks plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.4.10.3. This is due to the software allowing users to execute an action that does not properly validate the 'payload' value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.

NVD CVE-2026-3424Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2023-46639 · published 2025-01-02

Missing authorization check in kk Star Ratings (5.4.5 and older)

Affected
5.4.5 and older
Fixed in
5.4.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in FeedbackWP kk Star Ratings allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects kk Star Ratings: from n/a through 5.4.5.

NVD CVE-2023-46639Patchstack advisory

high 7.3 CVE-2024-11977 · published 2024-12-21

Remote code execution in kk Star Ratings (5.4.10 and older)

Affected
5.4.10 and older
Fixed in
5.4.10.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The kk Star Ratings – Rate Post & Collect User Feedbacks plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.4.10. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. Note: This vulnerability was only partially patched in version 5.4.10.1, and fully patched in 5.4.10.2

NVD CVE-2024-11977Wordfence advisoryPlugin source

medium 5.3 CVE-2023-36528 · published 2024-12-13

Missing authorization check in kk Star Ratings (5.4.3 and older)

Affected
5.4.3 and older
Fixed in
5.4.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in FeedbackWP kk Star Ratings allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects kk Star Ratings: from n/a through 5.4.3.

NVD CVE-2023-36528Patchstack advisory

medium 5.9 CVE-2023-4642 · published 2023-11-27

Security issue in kk Star Ratings (older than 5.4.6)

Affected
older than 5.4.6
Fixed in
5.4.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The kk Star Ratings WordPress plugin before 5.4.6 does not implement atomic operations, allowing one user vote multiple times on a poll due to a Race Condition.

NVD CVE-2023-4642WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
kk Star Ratings vulnerability status badge
<a href="https://laskyr.com/plugins/kk-star-ratings"><img src="https://laskyr.com/plugins/kk-star-ratings/badge.svg" alt="kk Star Ratings vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit