Skip to content
Laskyr

Plugins · jc-importer · data as of 2026-11-04

Is Import WP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.15.2)

As of 2026-11-04. 5 issues are on record for older versions; version 2.14.23 or newer fixes all of them that state a fix.

Latest version
2.15.2
Last updated
2026-10-08
Active installs
4,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Import and export WordPress posts, pages, users and media from any CSV or XML file, URL, FTP or Google Sheets — with visual field mapping. — by jcollings

What to do

  1. Update to the latest version (2.15.2). Anything older than 2.14.23 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get jc-importer --field=version shows what you run; wp plugin update jc-importer updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-14925 · published 2026-08-12

Information disclosure in Import WP (older than 2.14.23)

Affected
older than 2.14.23
Fixed in
2.14.23
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Import WP WordPress plugin before 2.14.23 does not perform any authorization check on one of its export-file download handlers, allowing unauthenticated attackers to download export files generated by administrators, which may contain user personal data such as email addresses, login names and roles. Exploitation requires an unconsumed export to already exist and a low-entropy, time-based download key to be obtained.

NVD CVE-2026-14925WPScan advisory

medium 5.3 CVE-2025-12894 · published 2025-11-21

Information disclosure in Import WP (2.14.17 and older)

Affected
2.14.17 and older
Fixed in
2.14.18 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Import WP – Export and Import CSV and XML files to WordPress plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.14.17 via the import/export functionality and a lack of .htaccess protection. This makes it possible for unauthenticated attackers to extract sensitive data from exports stored in /exportwp and import data stored in /importwp.

NVD CVE-2025-12894Wordfence advisoryCode change (fix)

medium 4.9 CVE-2025-12137 · published 2025-11-01

Path traversal / file read in Import WP (2.14.16 and older)

Affected
2.14.16 and older
Fixed in
2.14.17 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Import WP – Export and Import CSV and XML files to WordPress plugin for WordPress is vulnerable to Arbitrary File Read in all versions up to, and including, 2.14.16. This is due to the plugin's REST API endpoint accepting arbitrary absolute file paths without proper validation in the 'attach_file()' function when handling 'file_local' actions. This makes it possible for authenticated attackers, with administrator-level access and above, to read arbitrary files on the server's filesystem, including sensitive configuration files and system files via the 'local_url' parameter.

NVD CVE-2025-12137Wordfence advisoryCode change (fix)cwe.mitre.orggithub.comowasp.orgPlugin source

medium 6.1 CVE-2023-7253 · published 2024-04-24

Server-side request forgery (SSRF) in Import WP (older than 2.13.1)

Affected
older than 2.13.1
Fixed in
2.13.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Import WP WordPress plugin before 2.13.1 does not prevent users with the administrator role from pinging conducting SSRF attacks, which may be a problem in multisite configurations.

NVD CVE-2023-7253WPScan advisory

high 7.2 CVE-2022-1273 · published 2022-05-02

Remote code execution in Import WP (older than 2.4.6)

Affected
older than 2.4.6
Fixed in
2.4.6
Access needed (per CVSS)
Needs an admin-level account
Range from
advisory text · score by NVD
Details from the advisory

The Import WP WordPress plugin before 2.4.6 does not validate the imported file in some cases, allowing high privilege users such as admin to upload arbitrary files (such as PHP), leading to RCE

NVD CVE-2022-1273WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Import WP vulnerability status badge
<a href="https://laskyr.com/plugins/jc-importer"><img src="https://laskyr.com/plugins/jc-importer/badge.svg" alt="Import WP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit