Skip to content
Laskyr

Plugins · iwp-client · data as of 2026-11-04

Is InfiniteWP Client safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.13.10)

As of 2026-11-04. 6 issues are on record for older versions; version 1.13.10 or newer fixes all of them that state a fix.

Latest version
1.13.10
Last updated
2026-08-19
Active installs
200,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.0.8

Install this plugin on unlimited sites and manage them all from a central dashboard. This plugin communicates with your InfiniteWP Admin Panel. — by revmakx

What to do

  1. Update to the latest version (1.13.10). Anything older than 1.13.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get iwp-client --field=version shows what you run; wp plugin update iwp-client updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-17576 · published 2026-09-18

SQL injection in InfiniteWP Client (1.13.9 and older)

Affected
1.13.9 and older
Fixed in
1.13.10 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The InfiniteWP Client plugin for WordPress is vulnerable to SQL Injection via the get_comments action in versions up to, and including, 1.13.9. This is due to insufficient escaping on the array-key names supplied in the JSON request body before use in a SQL statement: IWP_MMB_Comment::get_comments() calls extract() on $args (which silently skips keys that are not valid PHP variable names) but a second foreach($args as $checkbox => $checkbox_val) processes every key, strips the 'iwp_get_comments_' prefix with str_replace(), wraps the remainder in single quotes, and imploded it into an IN(...) clause that is executed via $wpdb->get_results() with no prepare(). Because the request body is read from php://input and JSON-decoded, wp_magic_quotes() never touches the data, so quote characters in keys pass through unaltered. This makes it possible for authenticated attackers, with administrator-level access and above (an administrator can register their own public key via add_site using the plugin's WP-admin-generated activation_key and then issue signed get_comments requests), to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2026-17576Wordfence advisoryCode change (fix)Plugin source

high 7.6 CVE-2026-74011 · published 2026-08-20

SQL injection in InfiniteWP Client (1.13.9 and older)

Affected
1.13.9 and older
Fixed in
1.13.10
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in revmakx InfiniteWP Client allows Blind SQL Injection. This issue affects InfiniteWP Client: from n/a through 1.13.9.

NVD CVE-2026-74011Patchstack advisory

critical 9.8 CVE-2026-15038 · published 2026-08-09

Remote code execution in InfiniteWP Client (older than 1.13.6)

Affected
older than 1.13.6
Fixed in
1.13.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The InfiniteWP Client WordPress plugin before 1.13.6 does not properly verify the site-connection state and the authenticity of requests to its remote-management endpoint on WordPress Multisite installations, allowing unauthenticated attackers to bind their own key, hijack an administrator session, and take over the entire network, leading to remote code execution.

NVD CVE-2026-15038WPScan advisory

medium 5.3 CVE-2024-10585 · published 2025-01-08

Path traversal / file read in InfiniteWP Client (1.13.0 and older)

Affected
1.13.0 and older
Fixed in
1.13.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The InfiniteWP Client plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.13.0 via the 'historyID' parameter of the ~/debug-chart/index.php file. This makes it possible for unauthenticated attackers to read .txt files outside of the intended directory.

NVD CVE-2024-10585Wordfence advisoryCode change (fix)plugins.svn.wordpress.org

medium 5.9 CVE-2023-6565 · published 2024-02-29

Information disclosure in InfiniteWP Client (1.12.3 and older)

Affected
1.12.3 and older
Fixed in
1.12.3.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The InfiniteWP Client plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.12.3 via the multi-call backup option. This makes it possible for unauthenticated attackers to extract sensitive data from a temporary SQL file via repeated GET requests during the limited time window of the backup process.

NVD CVE-2023-6565Wordfence advisoryCode change (fix)

medium 5.3 CVE-2023-2916 · published 2023-08-15

Information disclosure in InfiniteWP Client (1.11.1 and older)

Affected
1.11.1 and older
Fixed in
1.12.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The InfiniteWP Client plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 1.11.1 via the 'admin_notice' function. This can allow authenticated attackers with subscriber-level permissions or above to extract sensitive data including configuration. It can only be exploited if the plugin has not been configured yet. If combined with another arbitrary plugin installation and activation vulnerability, it may be possible to connect a site to InfiniteWP which would make remote management possible and allow for elevation of privileges.

NVD CVE-2023-2916Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
InfiniteWP Client vulnerability status badge
<a href="https://laskyr.com/plugins/iwp-client"><img src="https://laskyr.com/plugins/iwp-client/badge.svg" alt="InfiniteWP Client vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit