Skip to content
Laskyr

Plugins · integracao-rd-station · data as of 2026-11-04

Is RD Station safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.7.4)

As of 2026-11-04. 3 issues are on record for older versions; version 5.7.0 or newer fixes all of them that state a fix.

Latest version
5.7.4
Last updated
2026-06-29
Active installs
20,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8

Integrate your contact forms with RD Station Marketing — by filipenasc

What to do

  1. Update to the latest version (5.7.4). Anything older than 5.7.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get integracao-rd-station --field=version shows what you run; wp plugin update integracao-rd-station updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.9 CVE-2026-49774 · published 2026-06-16

Remote code execution in RD Station (5.6.0 and older)

Affected
5.6.0 and older
Fixed in
5.7.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in Filipe Nasc RD Station allows Remote Code Inclusion. This issue affects RD Station: from n/a through 5.6.0.

NVD CVE-2026-49774Patchstack advisory

medium 5.4 CVE-2024-6894 · published 2024-09-05

Stored cross-site scripting (XSS) in RD Station (5.3.2 and older)

Affected
5.3.2 and older
Fixed in
5.4.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The RD Station plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 5.3.2 due to insufficient input sanitization and output escaping of post metaboxes added by the plugin. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-6894Wordfence advisoryCode change (fix)wordpress.orgPlugin source

high 8.8 CVE-2022-38139 · published 2022-09-13

Cross-site request forgery (CSRF) in RD Station (5.2.0 and older)

Affected
5.2.0 and older
Fixed in
5.2.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Multiple Cross-Site Request Forgery (CSRF) vulnerabilities in RD Station plugin <= 5.2.0 at WordPress.

NVD CVE-2022-38139Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
RD Station vulnerability status badge
<a href="https://laskyr.com/plugins/integracao-rd-station"><img src="https://laskyr.com/plugins/integracao-rd-station/badge.svg" alt="RD Station vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit