Plugins · insert-php · data as of 2026-11-04
Is Woody Code Snippets safe? Known vulnerabilities and latest version
- Latest version
- 2.7.10
- Last updated
- 2026-10-23
- Active installs
- 50,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Insert PHP, JavaScript, CSS, HTML, ads & tracking code into WordPress headers, footers, pages & content with conditional logic — no theme editing. — by Themeisle
What to do
- Update to the latest version (2.7.10). Anything older than 2.7.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get insert-php --field=version shows what you run; wp plugin update insert-php updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.9 CVE-2026-25366 · published 2026-03-25
Remote code execution in Woody Code Snippets (2.7.1 and older)
- Affected
- 2.7.1 and older
- Fixed in
- 2.7.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Generation of Code ('Code Injection') vulnerability in Themeisle Woody ad snippets insert-php allows Code Injection.This issue affects Woody ad snippets: from n/a through <= 2.7.1.
critical 9.9 CVE-2024-3105 · published 2024-06-15
Remote code execution in Woody Code Snippets (2.5.0 and older)
- Affected
- 2.5.0 and older
- Fixed in
- 2.6.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Woody code snippets – Insert Header Footer Code, AdSense Ads plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 2.5.0 via the 'insert_php' shortcode. This is due to the plugin not restricting the usage of the functionality to high level authorized users. This makes it possible for authenticated attackers, with contributor-level access and above, to execute code on the server.
NVD CVE-2024-3105Wordfence advisoryCode change (fix)Plugin source
medium 4.8 CVE-2024-35751 · published 2024-06-08
Stored cross-site scripting (XSS) in Woody Code Snippets (2.4.10 and older)
- Affected
- 2.4.10 and older
- Fixed in
- 2.6.0 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Creative Motion, Will Bontrager Software, LLC Woody ad snippets allows Stored XSS.This issue affects Woody ad snippets: from n/a through 2.4.10.
medium 4.3 CVE-2020-36759 · published 2023-10-20
Cross-site request forgery (CSRF) in Woody Code Snippets (older than 2.3.10)
- Affected
- older than 2.3.10
- Fixed in
- 2.3.10
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Woody code snippets plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.3.9. This is due to missing or incorrect nonce validation on the runActions() function. This makes it possible for unauthenticated attackers to activate and deactivate snippets via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2020-36759Wordfence advisoryCode change (fix)blog.nintechnet.comblog.nintechnet.comblog.nintechnet.comblog.nintechnet.com
medium 5.4 CVE-2019-16289 · published 2019-09-13
Cross-site scripting (XSS) in Woody Code Snippets (older than 2.2.8)
- Affected
- older than 2.2.8
- Fixed in
- 2.2.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The insert-php (aka Woody ad snippets) plugin before 2.2.8 for WordPress allows authenticated XSS via the winp_item parameter.
NVD CVE-2019-16289wordpress.orggeneraleg0x01.comwpvulndb.com
high 7.5 CVE-2019-14773 · published 2019-08-08
Security issue in Woody Code Snippets (2.2.5 and older)
- Affected
- 2.2.5 and older
- Fixed in
- 2.2.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by NVD
Details from the advisory
admin/includes/class.actions.snippet.php in the "Woody ad snippets" plugin through 2.2.5 for WordPress allows wp-admin/admin-post.php?action=close&post= deletion.
Recent activity
- 2026-10-23 — latest release on wordpress.org (2.7.10).
- 2026-03-25 — Remote code execution disclosed (CVE-2026-25366), fixed in 2.7.2.
- 2024-06-15 — Remote code execution disclosed (CVE-2024-3105), fixed in 2.6.0.
- 2024-06-08 — Stored cross-site scripting (XSS) disclosed (CVE-2024-35751), fixed in 2.6.0.
Get an email when Woody Code Snippets has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Woody Code Snippets (insert-php) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Themeisle (18 tracked)
Types found in this plugin: Remote code execution (2) · Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/insert-php (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/insert-php"><img src="https://laskyr.com/plugins/insert-php/badge.svg" alt="Woody Code Snippets vulnerability status"></a>