Skip to content
Laskyr

Plugins · inpost-gallery · data as of 2026-11-04

Is InPost Gallery safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.5)

As of 2026-11-04. 6 issues are on record for older versions; version 2.1.5 or newer fixes all of them that state a fix.

Latest version
2.1.5
Last updated
2026-03-06
Active installs
700+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.2+

InPost Gallery - photo and image gallery for WordPress — by RealMag777

What to do

  1. Update to the latest version (2.1.5). Anything older than 2.1.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get inpost-gallery --field=version shows what you run; wp plugin update inpost-gallery updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.3 CVE-2026-39574 · published 2026-06-16

SQL injection in InPost Gallery (2.1.4.6 and older)

Affected
2.1.4.6 and older
Fixed in
2.1.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in InPost Gallery <= 2.1.4.6 versions.

NVD CVE-2026-39574Patchstack advisory

high 7.5 CVE-2025-57889 · published 2025-09-05

File inclusion in InPost Gallery (2.1.4.5 and older)

Affected
2.1.4.5 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in RealMag777 InPost Gallery inpost-gallery allows PHP Local File Inclusion.This issue affects InPost Gallery: from n/a through <= 2.1.4.5.

NVD CVE-2025-57889Patchstack advisory

medium 4.3 CVE-2025-26903 · published 2025-04-15

Cross-site request forgery (CSRF) in InPost Gallery (2.1.4.3 and older)

Affected
2.1.4.3 and older
Fixed in
2.1.4.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in RealMag777 InPost Gallery inpost-gallery allows Cross Site Request Forgery.This issue affects InPost Gallery: from n/a through <= 2.1.4.3.

NVD CVE-2025-26903Patchstack advisory

medium 6.3 CVE-2024-11002 · published 2024-11-26

Remote code execution in InPost Gallery (2.1.4.2 and older)

Affected
2.1.4.2 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The InPost Gallery plugin for WordPress is vulnerable to arbitrary shortcode execution via the inpost_gallery_get_shortcode_template AJAX action in all versions up to, and including, 2.1.4.2. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes.

NVD CVE-2024-11002Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.4 CVE-2023-28666 · published 2023-03-22

Reflected cross-site scripting (XSS) in InPost Gallery (2.1.4.1 and older)

Affected
2.1.4.1 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The InPost Gallery WordPress plugin, in versions < 2.2.2, is affected by a reflected cross-site scripting vulnerability in the 'imgurl' parameter to the add_inpost_gallery_slide_item action, which can only be triggered by an authenticated user.

NVD CVE-2023-28666tenable.com

critical 9.8 CVE-2022-4063 · published 2022-12-19

Path traversal / file read in InPost Gallery (older than 2.1.4.1)

Affected
older than 2.1.4.1
Fixed in
2.1.4.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The InPost Gallery WordPress plugin before 2.1.4.1 insecurely uses PHP's extract() function when rendering HTML views, allowing attackers to force the inclusion of malicious files & URLs, which may enable them to run code on servers.

NVD CVE-2022-4063WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
InPost Gallery vulnerability status badge
<a href="https://laskyr.com/plugins/inpost-gallery"><img src="https://laskyr.com/plugins/inpost-gallery/badge.svg" alt="InPost Gallery vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit