Skip to content
Laskyr

Plugins · hummingbird-performance · data as of 2026-11-04

Is Hummingbird Performance safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.0)

As of 2026-11-04. 6 issues are on record for older versions; version 3.21.2 or newer fixes all of them that state a fix.

Latest version
4.0.0
Last updated
2026-11-03
Active installs
70,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Optimize PageSpeed Performance & Core Web Vitals, Advanced Cache, Minify CSS & JavaScript, Inline Critical CSS, Defer CSS & JS, Smush & Lazy Load, CDN — by WPMU DEV - Your All-in-One WordPress Platform

What to do

  1. Update to the latest version (4.0.0). Anything older than 3.21.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hummingbird-performance --field=version shows what you run; wp plugin update hummingbird-performance updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-83627 · published 2026-09-05

Remote code execution in Hummingbird Performance (3.21.0 and older)

Affected
3.21.0 and older
Fixed in
3.21.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hummingbird – Speed Optimization, Caching, Minify, Compress & CDN plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 3.21.0 via the log_msg() function in core/modules/class-page-cache.php. The page-cache debug log is written to wp-content/wphb-logs/page-caching-log.php, a directly web-accessible PHP file that is supposed to be protected by a leading '<?php die(); ?>' header. That header is guarded by class_exists( 'Filesystem' ), which can never match because class_exists() resolves string arguments in the global namespace while the class is Hummingbird\Core\Filesystem; when the log is created during a front-end request the header is therefore omitted entirely. get_cookies() then writes the raw name of any cookie matching the wphb_cache_ prefix into that file without sanitization. This makes it possible for unauthenticated attackers to write arbitrary PHP into the log file with a single anonymous request and execute it by requesting the file directly, resulting in full remote code execution. Exploitation requires the site administrator to have enabled Page Caching with the Debug Log option (non-default), and the log file to be created during a front-end request — a state reached by the plugin's own 'Clear logs' action, any cache flush, or unattended via the plugin's daily log-rotation cron, which can strip the protective header from an existing log file.

NVD CVE-2026-83627Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2026-19224 · published 2026-09-04

Remote code execution in Hummingbird Performance (3.15.0 up to (not including) 3.21.2)

Affected
3.15.0 up to (not including) 3.21.2
Fixed in
3.21.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Hummingbird Performance WordPress plugin before 3.21.2 does not restrict a network-wide setting to network administrators, allowing an administrator of any single site on a multisite network to execute arbitrary code across the entire network.

NVD CVE-2026-19224WPScan advisory

high 7.5 CVE-2025-14437 · published 2025-12-18

Information disclosure in Hummingbird Performance (3.18.0 and older)

Affected
3.18.0 and older
Fixed in
3.18.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hummingbird Performance plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.18.0 via the 'request' function. This makes it possible for unauthenticated attackers to extract sensitive data including Cloudflare API credentials.

NVD CVE-2025-14437Wordfence advisoryCode change (fix)

high 8.8 CVE-2024-43118 · published 2024-11-01

Missing authorization check in Hummingbird Performance (3.9.1 and older)

Affected
3.9.1 and older
Fixed in
3.9.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in WPMU DEV - Your All-in-One WordPress Platform Hummingbird hummingbird-performance.This issue affects Hummingbird: from n/a through <= 3.9.1.

NVD CVE-2024-43118Patchstack advisory

high 8.8 CVE-2024-43117 · published 2024-08-26

Cross-site request forgery (CSRF) in Hummingbird Performance (3.9.1 and older)

Affected
3.9.1 and older
Fixed in
3.9.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WPMU DEV - Your All-in-One WordPress Platform Hummingbird hummingbird-performance.This issue affects Hummingbird: from n/a through <= 3.9.1.

NVD CVE-2024-43117Patchstack advisory

medium 5.3 CVE-2024-32792 · published 2024-06-09

Missing authorization check in Hummingbird Performance (3.7.3 and older)

Affected
3.7.3 and older
Fixed in
3.7.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in WPMU DEV - Your All-in-One WordPress Platform Hummingbird hummingbird-performance.This issue affects Hummingbird: from n/a through <= 3.7.3.

NVD CVE-2024-32792Patchstack advisoryPatchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Hummingbird Performance vulnerability status badge
<a href="https://laskyr.com/plugins/hummingbird-performance"><img src="https://laskyr.com/plugins/hummingbird-performance/badge.svg" alt="Hummingbird Performance vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit