Skip to content
Laskyr

Plugins · http-headers · data as of 2026-11-04

Is HTTP Headers safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.19.6)

As of 2026-11-04. 7 issues are on record for older versions; version 1.19.3 or newer fixes all of them that state a fix.

Latest version
1.19.6
Last updated
2026-10-16
Active installs
40,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.3+

HTTP Headers adds CORS & security HTTP headers to your website. — by Dimitar Ivanov

What to do

  1. Update to the latest version (1.19.6). Anything older than 1.19.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get http-headers --field=version shows what you run; wp plugin update http-headers updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-4132 · published 2026-04-22

Remote code execution in HTTP Headers (1.19.2 and older)

Affected
1.19.2 and older
Fixed in
1.19.3 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HTTP Headers plugin for WordPress is vulnerable to External Control of File Name or Path leading to Remote Code Execution in all versions up to and including 1.19.2. This is due to insufficient validation of the file path stored in the 'hh_htpasswd_path' option and lack of sanitization on the 'hh_www_authenticate_user' option value. The plugin allows administrators to set an arbitrary file path for the htpasswd file location and does not validate that the path has a safe file extension (e.g., restricting to .htpasswd). Additionally, the username field used for HTTP Basic Authentication is written directly into the file without sanitization. The apache_auth_credentials() function constructs the file content using the unsanitized username via sprintf('%s:{SHA}%s', $user, ...), and update_auth_credentials() writes this content to the attacker-controlled path via file_put_contents(). This makes it possible for authenticated attackers, with Administrator-level access and above, to write arbitrary content (including PHP code) to arbitrary file paths on the server, effectively achieving Remote Code Execution.

NVD CVE-2026-4132Wordfence advisoryPlugin source

medium 5.5 CVE-2026-2717 · published 2026-04-22

Denial of service in HTTP Headers (1.19.2 and older)

Affected
1.19.2 and older
Fixed in
1.19.3 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HTTP Headers plugin for WordPress is vulnerable to CRLF Injection in all versions up to, and including, 1.19.2. This is due to insufficient sanitization of custom header name and value fields before writing them to the Apache .htaccess file via `insert_with_markers()`. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary newline characters and additional Apache directives into the .htaccess configuration file via the 'Custom Headers' settings, leading to Apache configuration parse errors and potential site-wide denial of service.

NVD CVE-2026-2717Wordfence advisoryPlugin source

medium 4.4 CVE-2026-1379 · published 2026-04-22

Stored cross-site scripting (XSS) in HTTP Headers (1.19.2 and older)

Affected
1.19.2 and older
Fixed in
1.19.3 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HTTP Headers plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.19.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-1379Wordfence advisoryPlugin source

medium 4.9 CVE-2023-37978 · published 2023-11-13

Server-side request forgery (SSRF) in HTTP Headers (1.18.11 and older)

Affected
1.18.11 and older
Fixed in
1.19.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Dimitar Ivanov HTTP Headers.This issue affects HTTP Headers: from n/a through 1.18.11.

NVD CVE-2023-37978Patchstack advisory

medium 4.8 CVE-2023-37874 · published 2023-08-05

Stored cross-site scripting (XSS) in HTTP Headers (1.18.11 and older)

Affected
1.18.11 and older
Fixed in
1.19.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Dimitar Ivanov HTTP Headers plugin <= 1.18.11 versions.

NVD CVE-2023-37874Patchstack advisory

high 7.2 CVE-2023-1208 · published 2023-07-10

Remote code execution in HTTP Headers (older than 1.18.11)

Affected
older than 1.18.11
Fixed in
1.18.11
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

This HTTP Headers WordPress plugin before 1.18.11 allows arbitrary data to be written to arbitrary files, leading to a Remote Code Execution vulnerability.

NVD CVE-2023-1208WPScan advisory

high 7.2 CVE-2023-1207 · published 2023-05-15

SQL injection in HTTP Headers (older than 1.18.8)

Affected
older than 1.18.8
Fixed in
1.18.8
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

This HTTP Headers WordPress plugin before 1.18.8 has an import functionality which executes arbitrary SQL on the server, leading to an SQL Injection vulnerability.

NVD CVE-2023-1207WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
HTTP Headers vulnerability status badge
<a href="https://laskyr.com/plugins/http-headers"><img src="https://laskyr.com/plugins/http-headers/badge.svg" alt="HTTP Headers vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit