Plugins · holiday-class-post-calendar · data as of 2026-11-04
Is Holiday class post calendar safe? Known vulnerabilities and latest version
- Latest version
- 7.2
- Last updated
- 2025-12-09
- Active installs
- 70+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 7.0+
投稿カレンダーに日曜、土曜、祭日及び独自の休日などのスタイル設定するためのclassを付加します。 — by strix-bubol5
What to do
- Update to the latest version (7.2). Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get holiday-class-post-calendar --field=version shows what you run; wp plugin update holiday-class-post-calendar updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.8 CVE-2025-12813 · published 2025-11-11
Remote code execution in Holiday class post calendar (7.1 and older)
- Affected
- 7.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Holiday class post calendar plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 7.1 via the 'contents' parameter. This is due to a lack of sanitization of user-supplied data when creating a cache file. This makes it possible for unauthenticated attackers to execute code on the server.
NVD CVE-2025-12813Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2025-12-09 — latest release on wordpress.org (7.2).
- 2025-11-11 — Remote code execution disclosed (CVE-2025-12813), fix version not stated.
Get an email when Holiday class post calendar has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Holiday class post calendar (holiday-class-post-calendar) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/holiday-class-post-calendar (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/holiday-class-post-calendar"><img src="https://laskyr.com/plugins/holiday-class-post-calendar/badge.svg" alt="Holiday class post calendar vulnerability status"></a>