Skip to content
Laskyr

Plugins · hivepress · data as of 2026-11-04

Is HivePress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.1)

As of 2026-11-04. 6 issues are on record for older versions; version 1.8.0 or newer fixes all of them that state a fix.

Latest version
1.8.1
Last updated
2026-10-21
Active installs
10,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

A simple yet powerful plugin to create a business directory, job board, real estate, classifieds, or basically any type of listing website. — by HivePress

What to do

  1. Update to the latest version (1.8.1). Anything older than 1.8.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hivepress --field=version shows what you run; wp plugin update hivepress updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.9 CVE-2026-110887 · published 2026-10-19

Remote code execution in HivePress (1.7.32 and older)

Affected
1.7.32 and older
Fixed in
1.8.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in HivePress HivePress hivepress allows Remote Code Inclusion.This issue affects HivePress: from n/a through 1.7.32.

NVD CVE-2026-110887Patchstack advisory

medium 6.5 CVE-2026-110885 · published 2026-10-18

Remote code execution in HivePress (1.7.32 and older)

Affected
1.7.32 and older
Fixed in
1.8.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in HivePress HivePress hivepress allows Code Injection.This issue affects HivePress: from n/a through 1.7.32.

NVD CVE-2026-110885Patchstack advisory

high 7.2 CVE-2026-109193 · published 2026-10-16

Stored cross-site scripting (XSS) in HivePress (1.7.32 and older)

Affected
1.7.32 and older
Fixed in
1.8.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HivePress – Business Directory, Listings & Classified Ads Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the '<custom user attribute slug> (e.g. hp_custom_link)' parameter in all versions up to, and including, 1.7.32 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has configured a custom user attribute with a display_format template placing the %value% token inside an href, src, or style attribute context, which is a documented and expected use of the plugin's attribute display feature.

NVD CVE-2026-109193Wordfence advisoryCode change (fix)github.comPlugin source

medium 6.4 CVE-2026-109388 · published 2026-10-16

Stored cross-site scripting (XSS) in HivePress (1.7.32 and older)

Affected
1.7.32 and older
Fixed in
1.8.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HivePress – Business Directory, Listings & Classified Ads Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'message' parameter in all versions up to, and including, 1.7.32 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that the site administrator has enabled user listing submission, and the script executes in the victim's browser at the moment of successful login via the embedded form on the attacker's listing page.

NVD CVE-2026-109388Wordfence advisoryCode change (fix)github.comPlugin source

high 7.2 CVE-2026-107657 · published 2026-10-10

Stored cross-site scripting (XSS) in HivePress (1.7.31 and older)

Affected
1.7.31 and older
Fixed in
1.7.32 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HivePress – Business Directory, Listings & Classified Ads Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the '<custom user attribute field name, e.g. profile_test>' parameter in all versions up to, and including, 1.7.31 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires an administrator to have configured a text-type custom user attribute whose display format places %value% inside an HTML attribute context (e.g., the documented pattern &lt;a href="%value%"&gt;Custom link&lt;/a&gt;), and for front-end user profiles to be enabled — both of which reflect the plugin's standard, documented configuration.

NVD CVE-2026-107657Wordfence advisorygithub.comPlugin source

medium 6.4 CVE-2026-103520 · published 2026-10-10

Stored cross-site scripting (XSS) in HivePress (1.7.31 and older)

Affected
1.7.31 and older
Fixed in
1.7.32 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HivePress – Business Directory, Listings & Classified Ads Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'custom text attribute (user-defined field name)' parameter in all versions up to, and including, 1.7.31 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when an administrator has configured a Text attribute whose display format places the %value% token inside an HTML attribute (e.g., title="%value%"), which is a documented HivePress pattern.

NVD CVE-2026-103520Wordfence advisorygithub.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
HivePress vulnerability status badge
<a href="https://laskyr.com/plugins/hivepress"><img src="https://laskyr.com/plugins/hivepress/badge.svg" alt="HivePress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit