Skip to content
Laskyr

Plugins · hippoo · data as of 2026-11-04

Is Hippoo Mobile App for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.12.1)

As of 2026-11-04. 7 issues are on record for older versions; version 1.12.1 or newer fixes all of them that state a fix.

Latest version
1.12.1
Last updated
2026-10-11
Active installs
1,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
6.9.11

Hippoo helps you manage WooCommerce orders, inventory, and analytics from your mobile. Receive real-time notifications and control your store on the g … — by hippooo

What to do

  1. Update to the latest version (1.12.1). Anything older than 1.12.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get hippoo --field=version shows what you run; wp plugin update hippoo updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-111601 · published 2026-10-17

Reflected cross-site scripting (XSS) in Hippoo Mobile App for WooCommerce (1.12.0 and older)

Affected
1.12.0 and older
Fixed in
1.12.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hippoo Mobile App for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'token_id' parameter in all versions up to, and including, 1.12.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. The URL path regex constrains the path segment to word characters, but WP_REST_Request's query-string parameter precedence allows a ?token_id= value to override it and reach the handler verbatim, bypassing the regex constraint entirely.

NVD CVE-2026-111601Wordfence advisoryCode change (fix)Plugin source

high 7.1 CVE-2026-108483 · published 2026-10-14

Reflected cross-site scripting (XSS) in Hippoo Mobile App for WooCommerce (1.12.0 and older)

Affected
1.12.0 and older
Fixed in
1.12.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in hippooo Hippoo Mobile App for WooCommerce hippoo allows Reflected XSS.This issue affects Hippoo Mobile App for WooCommerce: from n/a through 1.12.0.

NVD CVE-2026-108483Patchstack advisory

high 8.2 CVE-2026-49065 · published 2026-06-15

Missing authorization check in Hippoo Mobile App for WooCommerce (1.9.5 and older)

Affected
1.9.5 and older
Fixed in
1.9.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Hippoo Mobile App for WooCommerce <= 1.9.5 versions.

NVD CVE-2026-49065Patchstack advisory

critical 9.8 CVE-2026-49060 · published 2026-06-11

Privilege escalation in Hippoo Mobile App for WooCommerce (1.9.4 and older)

Affected
1.9.4 and older
Fixed in
1.9.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in Hippoo Mobile App for WooCommerce allows Privilege Escalation. This issue affects Hippoo Mobile App for WooCommerce: from n/a through 1.9.4.

NVD CVE-2026-49060Patchstack advisory

critical 9.8 CVE-2026-10580 · published 2026-06-05

Authentication bypass in Hippoo Mobile App for WooCommerce (1.9.4 and older)

Affected
1.9.4 and older
Fixed in
1.9.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hippoo Mobile App for WooCommerce plugin for WordPress is vulnerable to Authentication Bypass leading to Administrator Account Takeover in all versions up to and including 1.9.4. This is due to a logic conflation in HippooPermissions::get_user_permissions(), which returns the same null sentinel for both administrators and unauthenticated visitors — a value that HippooPermissions::has_role_access() unconditionally interprets as full administrator access — causing override_extension_permission_callback() to assign __return_true as the permission callback for every WordPress and WooCommerce REST route cloned under /wc-hippoo/v1/ext/ by HippooControllerWithAuth::re_register_external_routes(), while the block_unauthorized_access() pre-dispatch guard fails to block unauthenticated users for the same reason. This makes it possible for unauthenticated attackers to invoke any core REST endpoint without credentials — most critically, sending a POST request to /wc-hippoo/v1/ext/wp/v2/users/<id> with a {"password":"<new_password>"} body to reset the password of any WordPress user, including the site administrator, and gain full administrative control of the site.

NVD CVE-2026-10580Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2025-12655 · published 2025-12-12

Missing authorization check in Hippoo Mobile App for WooCommerce (1.7.1 and older)

Affected
1.7.1 and older
Fixed in
1.8.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hippoo Mobile App for WooCommerce plugin for WordPress is vulnerable to arbitrary file write via a missing authorization check in all versions up to, and including, 1.7.1. This is due to the REST API endpoint `/wp-json/hippoo/v1/wc/token/save_callback/{token_id}` being registered with `permission_callback => '__return_true'`, which allows unauthenticated access. This makes it possible for unauthenticated attackers to write arbitrary JSON content to the server's publicly accessible upload directory via the vulnerable endpoint.

NVD CVE-2025-12655Wordfence advisoryPlugin source

high 7.5 CVE-2025-13339 · published 2025-12-10

Path traversal / file read in Hippoo Mobile App for WooCommerce (1.7.1 and older)

Affected
1.7.1 and older
Fixed in
1.8.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Hippoo Mobile App for WooCommerce plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.7.1 via the template_redirect() function. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information.

NVD CVE-2025-13339Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Hippoo Mobile App for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/hippoo"><img src="https://laskyr.com/plugins/hippoo/badge.svg" alt="Hippoo Mobile App for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit