Skip to content
Laskyr

CVE-2026-111601: Hippoo Mobile App for WooCommerce reflected cross-site scripting (XSS) vulnerability

medium 6.1 published 2026-10-17 · updated 2026-10-19

Fixed in Hippoo Mobile App for WooCommerce 1.12.1 (first release after the affected range)

Hippoo Mobile App for WooCommerce 1.12.0 and older is affected by this reflected XSS issue. Sites on 1.12.1 or newer are not affected; the latest release is 1.12.1.

Affected versions
1.12.0 and older
Fixed in
1.12.1 *
Latest version
1.12.1
Severity
Medium · CVSS 6.1
Active installs
1,000+
Type
Reflected cross-site scripting (XSS)

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

What to do now

  1. Update Hippoo Mobile App for WooCommerce to 1.12.1 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Hippoo Mobile App for WooCommerce issue. With WP-CLI: wp plugin get hippoo --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Hippoo Mobile App for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'token_id' parameter in all versions up to, and including, 1.12.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. The URL path regex constrains the path segment to word characters, but WP_REST_Request's query-string parameter precedence allows a ?token_id= value to override it and reach the handler verbatim, bypassing the regex constraint entirely.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-111601.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit