Skip to content
Laskyr

Plugins · gsheetconnector-wpforms · data as of 2026-11-04

Is GSheetConnector safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.2.4)

As of 2026-11-04. 2 issues are on record for older versions; version 4.0.2 or newer fixes all of them that state a fix.

Latest version
4.2.4
Last updated
2026-11-02
Active installs
7,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Connect WPForms to Google Sheets and automatically send form entries to a google sheet in real-time. No manual exports, no coding required. — by WesternDeal

What to do

  1. Update to the latest version (4.2.4). Anything older than 4.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gsheetconnector-wpforms --field=version shows what you run; wp plugin update gsheetconnector-wpforms updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.9 CVE-2025-67979 · published 2026-02-20

Remote code execution in GSheetConnector (4.0.1 and older)

Affected
4.0.1 and older
Fixed in
4.0.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in WesternDeal WPForms Google Sheet Connector gsheetconnector-wpforms allows Code Injection.This issue affects WPForms Google Sheet Connector: from n/a through <= 4.0.1.

NVD CVE-2025-67979Patchstack advisory

medium 5.3 CVE-2025-67570 · published 2025-12-09

Missing authorization check in GSheetConnector (4.0.0 and older)

Affected
4.0.0 and older
Fixed in
4.0.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WesternDeal WPForms Google Sheet Connector gsheetconnector-wpforms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WPForms Google Sheet Connector: from n/a through <= 4.0.0.

NVD CVE-2025-67570Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GSheetConnector vulnerability status badge
<a href="https://laskyr.com/plugins/gsheetconnector-wpforms"><img src="https://laskyr.com/plugins/gsheetconnector-wpforms/badge.svg" alt="GSheetConnector vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit