Skip to content
Laskyr

Plugins · gptranslate · data as of 2026-11-04

Is GPTranslate safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.34.17)

As of 2026-11-04. 4 issues are on record for older versions; version 2.34.14 or newer fixes all of them that state a fix.

Latest version
2.34.17
Last updated
2026-10-16
Active installs
500+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Featured by WPTuts. Native AI Translation Agent that automatically translates your site with ChatGPT, Claude, Gemini, Grok, DeepSeek, DeepL and more. — by JExtensions Store

What to do

  1. Update to the latest version (2.34.17). Anything older than 2.34.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gptranslate --field=version shows what you run; wp plugin update gptranslate updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-103309 · published 2026-10-08

Stored cross-site scripting (XSS) in GPTranslate (older than 2.34.14)

Affected
older than 2.34.14
Fixed in
2.34.14
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The GPTranslate WordPress plugin before 2.34.14 does not properly restrict who can store translations, and does not escape them when outputting them in translated pages, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks when server-side translations are enabled.

NVD CVE-2026-103309WPScan advisory

medium 5.3 CVE-2026-89278 · published 2026-09-18

Information disclosure in GPTranslate (2.34.6 and older)

Affected
2.34.6 and older
Fixed in
2.34.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GPTranslate – Multilingual AI Translation Agent for WordPress: Translate Your Site with AI plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.34.6 via the enqueue_frontend_scripts. This makes it possible for unauthenticated attackers to extract the plaintext third-party AI provider API key (OpenAI, DeepL, xAI/Grok, Gemini, Claude, or Google Cloud Translation) — a credential granting billed account access — by fetching any public page and applying the inverse transformation bundled in the plugin's own public JavaScript asset. This exposure affects the default configuration (gpt-3.5-turbo in client mode) and all supported non-DeepSeek providers; only deepseek-* models and gpt-* models configured in server-proxy mode correctly suppress key emission.

NVD CVE-2026-89278Wordfence advisoryCode change (fix)Plugin source

critical 9.3 CVE-2026-49776 · published 2026-06-15

SQL injection in GPTranslate (2.32.6 and older)

Affected
2.32.6 and older
Fixed in
2.32.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in GPTranslate – Multilingual AI Translation for WordPress: Automatically Translate Websites <= 2.32.6 versions.

NVD CVE-2026-49776Patchstack advisory

high 7.2 CVE-2026-9109 · published 2026-06-13

Stored cross-site scripting (XSS) in GPTranslate (2.31 and older)

Affected
2.31 and older
Fixed in
2.32 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GPTranslate – Multilingual AI Translation for WordPress: Automatically Translate Websites plugin for WordPress is vulnerable to Stored Cross-Site Scripting via REST API Translation Storage in all versions up to, and including, 2.31 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The deterministically derived API key (sha256 of the site URL) is printed in the HTML source of every page via the JavaScript variable gptApiKey, meaning any unauthenticated visitor can retrieve the key and submit malicious translation payloads to the /wp-json/gptranslate/v1/request endpoint without any additional precondition.

NVD CVE-2026-9109Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GPTranslate vulnerability status badge
<a href="https://laskyr.com/plugins/gptranslate"><img src="https://laskyr.com/plugins/gptranslate/badge.svg" alt="GPTranslate vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit