Skip to content
Laskyr

CVE-2026-103309: GPTranslate stored cross-site scripting (XSS) vulnerability

high 7.5 published 2026-10-08

Fixed in GPTranslate 2.34.14

GPTranslate older than 2.34.14 is affected by this stored XSS issue. Sites on 2.34.14 or newer are not affected; the latest release is 2.34.17.

Affected versions
older than 2.34.14
Fixed in
2.34.14
Latest version
2.34.17
Severity
High · CVSS 7.5
Active installs
500+
Type
Stored cross-site scripting (XSS)

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

What to do now

  1. Update GPTranslate to 2.34.14 or newer (the latest is 2.34.17): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known GPTranslate issue. With WP-CLI: wp plugin get gptranslate --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The GPTranslate WordPress plugin before 2.34.14 does not properly restrict who can store translations, and does not escape them when outputting them in translated pages, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks when server-side translations are enabled.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-103309.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit