Plugins · gotmls · data as of 2026-11-04
Is Anti-Malware Security and Brute-Force Firewall safe? Known vulnerabilities and latest version
- Latest version
- 4.23.92
- Last updated
- 2026-10-27
- Active installs
- 100,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
This Anti-Malware scanner searches for Malware, Viruses, and other security threats and vulnerabilities on your server and it helps you fix them. — by Eli
What to do
- Update to the latest version (4.23.92). Anything older than 4.23.90 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gotmls --field=version shows what you run; wp plugin update gotmls updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.8 CVE-2026-57691 · published 2026-07-13
Reflected cross-site scripting (XSS) in Anti-Malware Security and Brute-Force Firewall (4.23.89 and older)
- Affected
- 4.23.89 and older
- Fixed in
- 4.23.90
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Eli Anti-Malware Security and Brute-Force Firewall gotmls allows Reflected XSS.This issue affects Anti-Malware Security and Brute-Force Firewall: from n/a through <= 4.23.89.
high 8.8 CVE-2026-39478 · published 2026-06-15
PHP object injection in Anti-Malware Security and Brute-Force Firewall (4.23.87 and older)
- Affected
- 4.23.87 and older
- Fixed in
- 4.23.88
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor PHP Object Injection in Anti-Malware Security and Brute-Force Firewall <= 4.23.87 versions.
medium 6.5 CVE-2025-11705 · published 2025-10-29
Path traversal / file read in Anti-Malware Security and Brute-Force Firewall (4.23.81 and older)
- Affected
- 4.23.81 and older
- Fixed in
- 4.23.83 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Anti-Malware Security and Brute-Force Firewall plugin for WordPress is vulnerable to Arbitrary File Read in all versions up to, and including, 4.23.81 due to a missing capability check combined with an information exposure in several GOTMLS_* AJAX actions. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
NVD CVE-2025-11705Wordfence advisoryCode change (fix)research.cleantalk.org
critical 9.0 CVE-2024-22144 · published 2024-04-25
Remote code execution in Anti-Malware Security and Brute-Force Firewall (4.21.96 and older)
- Affected
- 4.21.96 and older
- Fixed in
- 4.23.56
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Generation of Code ('Code Injection') vulnerability in Eli Scheetz Anti-Malware Security and Brute-Force Firewall gotmls allows Code Injection.This issue affects Anti-Malware Security and Brute-Force Firewall: from n/a through 4.21.96.
NVD CVE-2024-22144Patchstack advisoryPatchstack advisorysec.stealthcopter.com
medium 6.1 CVE-2022-2599 · published 2022-08-29
Reflected cross-site scripting (XSS) in Anti-Malware Security and Brute-Force Firewall (older than 4.21.83)
- Affected
- older than 4.21.83
- Fixed in
- 4.21.83
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Anti-Malware Security and Brute-Force Firewall WordPress plugin before 4.21.83 does not sanitise and escape some parameters before outputting them back in an admin dashboard, leading to Reflected Cross-Site Scripting
medium 6.1 CVE-2022-0953 · published 2022-04-25
Reflected cross-site scripting (XSS) in Anti-Malware Security and Brute-Force Firewall (older than 4.20.96)
- Affected
- older than 4.20.96
- Fixed in
- 4.20.96
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Anti-Malware Security and Brute-Force Firewall WordPress plugin before 4.20.96 does not sanitise and escape the QUERY_STRING before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting in browsers which do not encode characters
medium 4.8 CVE-2021-25101 · published 2022-02-21
Reflected cross-site scripting (XSS) in Anti-Malware Security and Brute-Force Firewall (older than 4.20.94)
- Affected
- older than 4.20.94
- Fixed in
- 4.20.94
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Anti-Malware Security and Brute-Force Firewall WordPress plugin before 4.20.94 does not sanitise and escape the POST data before outputting it back in attributes of an admin page, leading to a Reflected Cross-Site scripting. Due to the presence of specific parameter value, available to admin users, this can only be exploited by an admin against another admin user.
Recent activity
- 2026-10-27 — latest release on wordpress.org (4.23.92).
- 2026-07-13 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-57691), fixed in 4.23.90.
- 2026-06-15 — PHP object injection disclosed (CVE-2026-39478), fixed in 4.23.88.
- 2025-10-29 — Path traversal / file read disclosed (CVE-2025-11705), fixed in 4.23.83.
Get an email when Anti-Malware Security and Brute-Force Firewall has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Anti-Malware Security and Brute-Force Firewall (gotmls) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · PHP object injection (1) · Path traversal and file read (1) · Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gotmls (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gotmls"><img src="https://laskyr.com/plugins/gotmls/badge.svg" alt="Anti-Malware Security and Brute-Force Firewall vulnerability status"></a>