Skip to content
Laskyr

Plugins · google-analytics-dashboard-for-wp · data as of 2026-11-04

Is ExactMetrics safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (10.3.0)

As of 2026-11-04. 6 issues are on record for older versions; version 9.1.3 or newer fixes all of them that state a fix.

Latest version
10.3.0
Last updated
2026-09-16
Active installs
200,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Connects Google Analytics with your WordPress site. Displays stats to help you understand your users and site content on a whole new level! — by Syed Balkhi

What to do

  1. Update to the latest version (10.3.0). Anything older than 9.1.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get google-analytics-dashboard-for-wp --field=version shows what you run; wp plugin update google-analytics-dashboard-for-wp updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-5488 · published 2026-04-24

Missing authorization check in ExactMetrics (9.1.2 and older)

Affected
9.1.2 and older
Fixed in
9.1.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ExactMetrics – Google Analytics Dashboard for WordPress plugin for WordPress is vulnerable to Missing Authorization in versions up to and including 9.1.2. This is due to missing capability checks in the get_ads_access_token() and reset_experience() AJAX handlers. While the mi-admin-nonce is localized on all admin pages (including profile.php which subscribers can access), and while other similar AJAX endpoints in the same class properly check for the exactmetrics_save_settings capability, these two endpoints only verify the nonce. This makes it possible for authenticated attackers, with subscriber-level access and above, to retrieve valid Google Ads access tokens and reset Google Ads integration settings.

NVD CVE-2026-5488Wordfence advisoryCode change (fix)research.cleantalk.orgPlugin source

high 7.2 CVE-2026-5464 · published 2026-04-23

Remote code execution in ExactMetrics (9.1.2 and older)

Affected
9.1.2 and older
Fixed in
9.1.3 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ExactMetrics – Google Analytics Dashboard for WordPress (Website Stats Plugin) plugin for WordPress is vulnerable to unauthorized arbitrary plugin installation and activation in all versions up to, and including, 9.1.2. This is due to the reports page exposing the 'onboarding_key' transient to any user with the 'exactmetrics_view_dashboard' capability. This key is the sole authorization gate for the '/wp-json/exactmetrics/v1/onboarding/connect-url' REST endpoint, which returns a one-time hash (OTH) token. This OTH token is then the only credential checked by the 'exactmetrics_connect_process' AJAX endpoint — which has no capability check, no nonce verification, and accepts an arbitrary plugin ZIP URL via the file parameter for installation and activation. This makes it possible for authenticated attackers, with Editor-level access and above granted the report viewing permission, to install and activate arbitrary plugins from attacker-controlled URLs, leading to Remote Code Execution.

NVD CVE-2026-5464Wordfence advisoryPlugin source

high 8.8 CVE-2026-1992 · published 2026-03-11

Remote code execution in ExactMetrics (8.0.0 to 9.0.2)

Affected
8.0.0 to 9.0.2
Fixed in
9.0.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ExactMetrics – Google Analytics Dashboard for WordPress plugin is vulnerable to Insecure Direct Object Reference in versions 8.6.0 through 9.0.2. This is due to the `store_settings()` method in the `ExactMetrics_Onboarding` class accepting a user-supplied `triggered_by` parameter that is used instead of the current user's ID to check permissions. This makes it possible for authenticated attackers with the `exactmetrics_save_settings` capability to bypass the `install_plugins` capability check by specifying an administrator's user ID in the `triggered_by` parameter, allowing them to install arbitrary plugins and achieve Remote Code Execution. This vulnerability only affects sites on which administrator has given other user types the permission to view reports and can only be exploited by users of that type.

NVD CVE-2026-1992Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2026-1993 · published 2026-03-11

Privilege escalation in ExactMetrics (7.1.0 to 9.0.2)

Affected
7.1.0 to 9.0.2
Fixed in
9.0.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ExactMetrics – Google Analytics Dashboard for WordPress plugin is vulnerable to Improper Privilege Management in versions 7.1.0 through 9.0.2. This is due to the `update_settings()` function accepting arbitrary plugin setting names without a whitelist of allowed settings. This makes it possible for authenticated attackers with the `exactmetrics_save_settings` capability to modify any plugin setting, including the `save_settings` option that controls which user roles have access to plugin functionality. The admin intended to delegate configuration access to a trusted user, not enable that user to delegate access to everyone. By setting `save_settings` to include `subscriber`, an attacker can grant plugin administrative access to all subscribers on the site.

NVD CVE-2026-1993Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2025-24750 · published 2025-01-24

Missing authorization check in ExactMetrics (8.1.0 and older)

Affected
8.1.0 and older
Fixed in
8.2.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Syed Balkhi ExactMetrics google-analytics-dashboard-for-wp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ExactMetrics: from n/a through <= 8.1.0.

NVD CVE-2025-24750Patchstack advisory

medium 5.4 CVE-2023-23880 · published 2023-08-08

Stored cross-site scripting (XSS) in ExactMetrics (7.14.1 and older)

Affected
7.14.1 and older
Fixed in
7.14.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in ExactMetrics plugin <= 7.14.1 versions.

NVD CVE-2023-23880Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ExactMetrics vulnerability status badge
<a href="https://laskyr.com/plugins/google-analytics-dashboard-for-wp"><img src="https://laskyr.com/plugins/google-analytics-dashboard-for-wp/badge.svg" alt="ExactMetrics vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit