Plugins · geeky-bot · data as of 2026-11-04
Is Geeky Bot safe? Known vulnerabilities and latest version
- Latest version
- 2.1.2
- Last updated
- 2026-10-22
- Active installs
- 6,000+
- Known issues on record
- 8
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
AI chatbot for WooCommerce that answers product and policy questions, finds products in plain language, and recommends what to buy. — by GeekyBot
What to do
- Update to the latest version (2.1.2). Anything older than 1.2.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get geeky-bot --field=version shows what you run; wp plugin update geeky-bot updates it.
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-61965 · published 2026-08-13
Cross-site scripting (XSS) in Geeky Bot (1.2.6 and older)
- Affected
- 1.2.6 and older
- Fixed in
- 1.2.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in GeekyBot <= 1.2.6 versions.
high 7.5 CVE-2026-15048 · published 2026-07-31
Information disclosure in Geeky Bot (older than 1.2.8)
- Affected
- older than 1.2.8
- Fixed in
- 1.2.8
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Geeky Bot WordPress plugin before 1.2.8 does not perform an authorization check on one of its AJAX actions, allowing unauthenticated users to retrieve chat-history session metadata including WordPress usernames, user IDs, and timestamps.
critical 9.3 CVE-2026-57679 · published 2026-07-02
SQL injection in Geeky Bot (1.2.5 and older)
- Affected
- 1.2.5 and older
- Fixed in
- 1.2.6
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated SQL Injection in GeekyBot <= 1.2.5 versions.
critical 10.0 CVE-2026-40772 · published 2026-06-15
Arbitrary file upload in Geeky Bot (1.2.2 and older)
- Affected
- 1.2.2 and older
- Fixed in
- 1.2.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Arbitrary File Upload in GeekyBot <= 1.2.2 versions.
critical 9.3 CVE-2026-39519 · published 2026-06-15
SQL injection in Geeky Bot (1.2.0 and older)
- Affected
- 1.2.0 and older
- Fixed in
- 1.2.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated SQL Injection in GeekyBot <= 1.2.0 versions.
critical 9.8 CVE-2026-5294 · published 2026-05-05
Remote code execution in Geeky Bot (1.2.2 and older)
- Affected
- 1.2.2 and older
- Fixed in
- 1.2.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Geeky Bot plugin for WordPress is vulnerable to Missing Authorization in versions up to, and including, 1.2.2. This is due to a nopriv AJAX route allowing attacker-controlled model/function dispatch and reaching a plugin installer helper that downloads and unzips attacker-supplied ZIP files into wp-content/plugins/. This makes it possible for unauthenticated attackers to perform arbitrary plugin installation and achieve remote code execution.
high 7.5 CVE-2026-3456 · published 2026-05-05
SQL injection in Geeky Bot (1.2.0 and older)
- Affected
- 1.2.0 and older
- Fixed in
- 1.2.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The GeekyBot — Generate AI Content Without Prompt, Chatbot and Lead Generation plugin for WordPress is vulnerable to SQL Injection via the 'attributekey' parameter in versions up to, and including, 1.2.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
high 7.2 CVE-2025-15266 · published 2026-01-14
Stored cross-site scripting (XSS) in Geeky Bot (1.1.8 and older)
- Affected
- 1.1.8 and older
- Fixed in
- 1.2.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The GeekyBot — Generate AI Content Without Prompt, Chatbot and Lead Generation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the chat message field in all versions up to, and including, 1.1.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an administrator accesses the Chat History page.
NVD CVE-2025-15266Wordfence advisoryCode change (fix)wordpress.org
Recent activity
- 2026-10-22 — latest release on wordpress.org (2.1.2).
- 2026-08-13 — Cross-site scripting (XSS) disclosed (CVE-2026-61965), fixed in 1.2.7.
- 2026-07-31 — Information disclosure disclosed (CVE-2026-15048), fixed in 1.2.8.
- 2026-07-02 — SQL injection disclosed (CVE-2026-57679), fixed in 1.2.6.
Get an email when Geeky Bot has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Geeky Bot (geeky-bot) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (3) · Cross-site scripting (XSS) (2) · Sensitive data exposure (1) · Arbitrary file upload (1) · Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/geeky-bot (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/geeky-bot"><img src="https://laskyr.com/plugins/geeky-bot/badge.svg" alt="Geeky Bot vulnerability status"></a>