Plugins · food-and-drink-menu · data as of 2026-11-04
Is Five Star Restaurant Menu and Food Ordering safe? Known vulnerabilities and latest version
- Latest version
- 2.7.0
- Last updated
- 2026-10-22
- Active installs
- 5,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
Restaurant menu and food ordering system that is easy to set up and integrates with any theme. Includes restaurant menu blocks and patterns. — by Rustaurius
What to do
- Update to the latest version (2.7.0). Anything older than 2.5.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get food-and-drink-menu --field=version shows what you run; wp plugin update food-and-drink-menu updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-54835 · published 2026-06-26
Missing authorization check in Five Star Restaurant Menu and Food Ordering (2.5.2 and older)
- Affected
- 2.5.2 and older
- Fixed in
- 2.5.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Five Star Restaurant Menu <= 2.5.2 versions.
medium 4.3 CVE-2024-5459 · published 2024-06-05
Missing authorization check in Five Star Restaurant Menu and Food Ordering (2.4.16 and older)
- Affected
- 2.4.16 and older
- Fixed in
- 2.4.17 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Restaurant Menu and Food Ordering plugin for WordPress is vulnerable to unauthorized creation of data due to a missing capability check on 'add_section', 'add_menu', 'add_menu_item', and 'add_menu_page' functions in all versions up to, and including, 2.4.16. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create menu sections, menus, food items, and new menu pages.
NVD CVE-2024-5459Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2024-29089 · published 2024-03-19
Stored cross-site scripting (XSS) in Five Star Restaurant Menu and Food Ordering (2.4.14 and older)
- Affected
- 2.4.14 and older
- Fixed in
- 2.4.15
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Five Star Plugins Five Star Restaurant Menu allows Stored XSS.This issue affects Five Star Restaurant Menu: from n/a through 2.4.14.
critical 9.8 CVE-2023-5340 · published 2023-11-20
PHP object injection in Five Star Restaurant Menu and Food Ordering (older than 2.4.11)
- Affected
- older than 2.4.11
- Fixed in
- 2.4.11
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Five Star Restaurant Menu and Food Ordering WordPress plugin before 2.4.11 unserializes user input via an AJAX action available to unauthenticated users, allowing them to perform PHP Object Injection when a suitable gadget is present on the blog.
high 8.8 CVE-2023-37985 · published 2023-07-17
Cross-site request forgery (CSRF) in Five Star Restaurant Menu and Food Ordering (2.4.6 and older)
- Affected
- 2.4.6 and older
- Fixed in
- 2.4.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in FiveStarPlugins Restaurant Menu and Food Ordering plugin <= 2.4.6 versions.
critical 9.8 CVE-2020-29045 · published 2021-03-11
Remote code execution in Five Star Restaurant Menu and Food Ordering (2.2.0 and older)
- Affected
- 2.2.0 and older
- Fixed in
- 2.2.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by NVD
Details from the advisory
The food-and-drink-menu plugin through 2.2.0 for WordPress allows remote attackers to execute arbitrary code because of an unserialize operation on the fdm_cart cookie in load_cart_from_cookie in includes/class-cart-manager.php.
Recent activity
- 2026-10-22 — latest release on wordpress.org (2.7.0).
- 2026-06-26 — Missing authorization check disclosed (CVE-2026-54835), fixed in 2.5.3.
- 2024-06-05 — Missing authorization check disclosed (CVE-2024-5459), fixed in 2.4.17.
- 2024-03-19 — Stored cross-site scripting (XSS) disclosed (CVE-2024-29089), fixed in 2.4.15.
Get an email when Five Star Restaurant Menu and Food Ordering has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Five Star Restaurant Menu and Food Ordering (food-and-drink-menu) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Rustaurius (7 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1) · PHP object injection (1) · Cross-site request forgery (CSRF) (1) · Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/food-and-drink-menu (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/food-and-drink-menu"><img src="https://laskyr.com/plugins/food-and-drink-menu/badge.svg" alt="Five Star Restaurant Menu and Food Ordering vulnerability status"></a>