Skip to content
Laskyr

Plugins · firebox · data as of 2026-11-04

Is FireBox safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.15)

As of 2026-11-04. 4 issues are on record for older versions; version 3.1.14 or newer fixes all of them that state a fix.

Latest version
3.1.15
Last updated
2026-10-22
Active installs
6,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Newsletter optins, discount coupon popups, sticky bars and lightbox modals that capture leads and recover abandoned WooCommerce carts. — by FirePlugins

What to do

  1. Update to the latest version (3.1.15). Anything older than 3.1.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get firebox --field=version shows what you run; wp plugin update firebox updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-104724 · published 2026-10-10

SQL injection in FireBox (3.1.13 and older)

Affected
3.1.13 and older
Fixed in
3.1.14 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment plugin for WordPress is vulnerable to generic SQL Injection via FireBox Form Display Condition in all versions up to, and including, 3.1.13 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with author-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. On fresh installations of version 3.1.10 and later, exploitation requires administrator-level access; however, on sites upgraded from a version prior to 3.1.10, the preserveCampaignRoleAccess() migration grants the edit_fireboxes capability to any role that previously held edit_posts, reducing the minimum required privilege to Author-level.

NVD CVE-2026-104724Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2026-76801 · published 2026-09-09

Remote code execution in FireBox (3.1.10 and older)

Affected
3.1.10 and older
Fixed in
3.1.11 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 3.1.10 via the value function. This is due to a trivially bypassable regex blacklist in Executer::allowedToRun() that fails to block WordPress core functions such as wp_insert_user, update_option, and file_put_contents, combined with no sanitization of PHP condition rule values stored via the firebox_meta REST endpoint. This makes it possible for authenticated attackers, with author-level access and above, to execute code on the server. On sites upgraded from a version prior to 3.1.10, the Migrator::preserveCampaignRoleAccess() function automatically grants the edit_fireboxes and publish_fireboxes capabilities to the Author role, lowering the effective entry point to Author-level access.

NVD CVE-2026-76801Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2026-12120 · published 2026-06-18

Information disclosure in FireBox (3.1.7 and older)

Affected
3.1.7 and older
Fixed in
3.1.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FireBox Popups – Increase Sales and Grow Your Email List plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.1.7 via the 'form_id' parameter. This makes it possible for unauthenticated attackers to extract download a full CSV export of all form submissions — including any personally identifiable information submitted by users — for any arbitrary form_id.

NVD CVE-2026-12120Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-67545 · published 2025-12-09

Stored cross-site scripting (XSS) in FireBox (3.1.0 and older)

Affected
3.1.0 and older
Fixed in
3.1.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
advisory text · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in FirePlugins FireBox firebox allows Stored XSS.This issue affects FireBox: from n/a through <= 3.1.0-free.

NVD CVE-2025-67545Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FireBox vulnerability status badge
<a href="https://laskyr.com/plugins/firebox"><img src="https://laskyr.com/plugins/firebox/badge.svg" alt="FireBox vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit