Plugins · file-manager · data as of 2026-11-04
Is File Manager safe? Known vulnerabilities and latest version
- Latest version
- 7.0
- Last updated
- 2026-10-29
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
Manage WordPress files and folders from your dashboard with a built-in code editor: upload, edit, delete, move, rename, and archive, no FTP needed. — by Bit Apps
What to do
- Update to the latest version (7.0). Anything older than 6.9.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get file-manager --field=version shows what you run; wp plugin update file-manager updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-15991 · published 2026-08-06
Arbitrary file deletion in File Manager (6.0 to 6.9)
- Affected
- 6.0 to 6.9
- Fixed in
- 6.9.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The File Manager plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the connector function in all versions from 6.0 - 6.9. This makes it possible for authenticated attackers, with subscriber-level access and above, to read and delete arbitrary files on the server, which can lead to remote code execution when the right file is deleted (such as wp-config.php). The bypass is triggered by passing cmd=rm or cmf=file in the URL query string of a POST request: elFinder's bind registration reads the command exclusively from $_POST and therefore never registers the rm.pre permission handler, while the dispatcher reads from the merged $_GET+$_POST superglobal and executes the rm or file command unchecked against a volume that defaults to ABSPATH.
NVD CVE-2026-15991Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2025-1725 · published 2025-06-03
Stored cross-site scripting (XSS) in File Manager (6.7 and older)
- Affected
- 6.7 and older
- Fixed in
- 6.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Bit File Manager – 100% Free & Open Source File Manager and Code Editor for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 6.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
high 8.8 CVE-2024-7770 · published 2024-09-10
Arbitrary file upload in File Manager (6.5.5 and older)
- Affected
- 6.5.5 and older
- Fixed in
- 6.5.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Bit File Manager – 100% Free & Open Source File Manager and Code Editor for WordPress plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'upload' function in all versions up to, and including, 6.5.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, and granted upload permissions by an administrator, to upload arbitrary files on the affected site's server which may make remote code execution possible.
NVD CVE-2024-7770Wordfence advisoryCode change (fix)Plugin source
high 8.1 CVE-2024-7627 · published 2024-09-05
Remote code execution in File Manager (6.0 to 6.5.5)
- Affected
- 6.0 to 6.5.5
- Fixed in
- 6.5.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Bit File Manager plugin for WordPress is vulnerable to Remote Code Execution in versions 6.0 to 6.5.5 via the 'checkSyntax' function. This is due to writing a temporary file to a publicly accessible directory before performing file validation. This makes it possible for unauthenticated attackers to execute code on the server if an administrator has allowed Guest User read permissions.
NVD CVE-2024-7627Wordfence advisoryCode change (fix)Plugin source
high 7.2 CVE-2022-47599 · published 2023-12-20
PHP object injection in File Manager (5.2.7 and older)
- Affected
- 5.2.7 and older
- Fixed in
- 6.0.0
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Deserialization of Untrusted Data vulnerability in File Manager by Bit Form Team File Manager – 100% Free & Open Source File Manager Plugin for WordPress | Bit File Manager.This issue affects File Manager – 100% Free & Open Source File Manager Plugin for WordPress | Bit File Manager: from n/a through 5.2.7.
high 7.5 CVE-2018-7204 · published 2018-03-07
Information disclosure in File Manager (5.0.0 and older)
- Affected
- 5.0.0 and older
- Fixed in
- 5.2.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
inc/logger.php in the Giribaz File Manager plugin before 5.0.2 for WordPress logged activity related to the plugin in /wp-content/uploads/file-manager/log.txt. If a user edits the wp-config.php file using this plugin, the wp-config.php contents get added to log.txt, which is not protected and contains database credentials, salts, etc. These files have been indexed by Google and a simple dork will find affected sites.
Recent activity
- 2026-10-29 — latest release on wordpress.org (7.0).
- 2026-08-06 — Arbitrary file deletion disclosed (CVE-2026-15991), fixed in 6.9.1.
- 2025-06-03 — Stored cross-site scripting (XSS) disclosed (CVE-2025-1725), fixed in 6.8.
- 2024-09-10 — Arbitrary file upload disclosed (CVE-2024-7770), fixed in 6.5.6.
Get an email when File Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for File Manager (file-manager) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Bit Apps (6 tracked)
Types found in this plugin: Arbitrary file deletion (1) · Cross-site scripting (XSS) (1) · Arbitrary file upload (1) · Remote code execution (1) · PHP object injection (1) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/file-manager (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/file-manager"><img src="https://laskyr.com/plugins/file-manager/badge.svg" alt="File Manager vulnerability status"></a>