Plugins · extensive-vc-addon · data as of 2026-11-04
Is Extensive VC Addons for WPBakery Page Builder safe? Known vulnerabilities and latest version
- Latest version
- 2.2
- Last updated
- 2026-11-02
- Active installs
- 4,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.2+
Extensive addons or extensions for WPBakery page builder, which allows you to add unique, flexible and fully responsive shortcodes — by Nenad Obradovic
What to do
- Update to the latest version (2.2). Anything older than 2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get extensive-vc-addon --field=version shows what you run; wp plugin update extensive-vc-addon updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.1 CVE-2025-60087 · published 2026-02-20
File inclusion in Extensive VC Addons for WPBakery Page Builder (1.9.1 and older)
- Affected
- 1.9.1 and older
- Fixed in
- 2.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Nenad Obradovic Extensive VC Addons for WPBakery page builder extensive-vc-addon allows PHP Local File Inclusion.This issue affects Extensive VC Addons for WPBakery page builder: from n/a through <= 1.9.1.
high 8.1 CVE-2025-14475 · published 2025-12-13
File inclusion in Extensive VC Addons for WPBakery Page Builder (1.9.1 and older)
- Affected
- 1.9.1 and older
- Fixed in
- 2.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Extensive VC Addons for WPBakery page builder plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.9.1 via the `extensive_vc_get_module_template_part` function. This is due to insufficient path normalization and validation of the user-supplied `shortcode_name` parameter in the `extensive_vc_init_shortcode_pagination` AJAX action. This makes it possible for unauthenticated attackers to include and execute arbitrary PHP files on the server, allowing the execution of any PHP code in those files via the `shortcode_name` parameter.
high 7.5 CVE-2023-0159 · published 2023-02-13
Remote code execution in Extensive VC Addons for WPBakery Page Builder (older than 1.9.1)
- Affected
- older than 1.9.1
- Fixed in
- 1.9.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Extensive VC Addons for WPBakery page builder WordPress plugin before 1.9.1 does not validate a parameter passed to the php extract function when loading templates, allowing an unauthenticated attacker to override the template path to read arbitrary files from the hosts file system. This may be escalated to RCE using PHP filter chains.
Recent activity
- 2026-11-02 — latest release on wordpress.org (2.2).
- 2026-02-20 — File inclusion disclosed (CVE-2025-60087), fixed in 2.0.
- 2025-12-13 — File inclusion disclosed (CVE-2025-14475), fixed in 2.0.
- 2023-02-13 — Remote code execution disclosed (CVE-2023-0159), fixed in 1.9.1.
Get an email when Extensive VC Addons for WPBakery Page Builder has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Extensive VC Addons for WPBakery Page Builder (extensive-vc-addon) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: File inclusion (2) · Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/extensive-vc-addon (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/extensive-vc-addon"><img src="https://laskyr.com/plugins/extensive-vc-addon/badge.svg" alt="Extensive VC Addons for WPBakery Page Builder vulnerability status"></a>