Skip to content
Laskyr

Plugins · expivi · data as of 2026-11-04

Is 3D Product configurator for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.16.3)

As of 2026-11-04. 1 issue is on record for older versions; version 2.16.3 or newer fixes all of them that state a fix.

Latest version
2.16.3
Last updated
2026-10-01
Active installs
100+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Easy-to-use 3D product configurator to show your products in 360° — by Expivi

What to do

  1. Update to the latest version (2.16.3). Anything older than 2.16.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get expivi --field=version shows what you run; wp plugin update expivi updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-103889 · published 2026-10-10

Remote code execution in 3D Product configurator for WooCommerce (2.16.2 and older)

Affected
2.16.2 and older
Fixed in
2.16.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The 3D Product configurator for WooCommerce plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 2.16.2 via the 'xpv_image' parameter parameter. This is due to missing authentication and nonce checks on the wp_loaded handler combined with no sanitization of the xpv_image POST parameter before it is echoed unescaped into a Dompdf-rendered HTML template with PHP execution enabled. This makes it possible for unauthenticated attackers to execute code on the server. The only nonce and authentication check in the handler is entirely enclosed in a block comment with no replacement, making the endpoint reachable via a single unauthenticated POST to any URL on the site.

NVD CVE-2026-103889Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
3D Product configurator for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/expivi"><img src="https://laskyr.com/plugins/expivi/badge.svg" alt="3D Product configurator for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit