Plugins · event-tickets-with-ticket-scanner · data as of 2026-11-04
Is Event Tickets with Ticket Scanner safe? Known vulnerabilities and latest version
- Latest version
- 3.3.1
- Last updated
- 2026-11-03
- Active installs
- 1,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.1+
Sell tickets on your site: seating plans, PDF tickets with QR codes, a built-in POS for door sales (box office), and a scanner app — no per-ticket ser … — by Vollstart
What to do
- Update to the latest version (3.3.1). Anything older than 2.8.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get event-tickets-with-ticket-scanner --field=version shows what you run; wp plugin update event-tickets-with-ticket-scanner updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.0 CVE-2025-68015 · published 2026-01-22
Remote code execution in Event Tickets with Ticket Scanner (2.8.5 and older)
- Affected
- 2.8.5 and older
- Fixed in
- 2.8.6
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Generation of Code ('Code Injection') vulnerability in Vollstart Event Tickets with Ticket Scanner event-tickets-with-ticket-scanner allows Code Injection.This issue affects Event Tickets with Ticket Scanner: from n/a through <= 2.8.5.
low 3.5 CVE-2024-6711 · published 2025-05-15
Cross-site scripting (XSS) in Event Tickets with Ticket Scanner (older than 2.3.8)
- Affected
- older than 2.3.8
- Fixed in
- 2.3.8
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Event Tickets with Ticket Scanner WordPress plugin before 2.3.8 does not sanitise and escape some parameters, which could allow users with a role as low as admin to perform Cross-Site Scripting attacks
medium 4.3 CVE-2025-1762 · published 2025-03-28
Cross-site request forgery (CSRF) in Event Tickets with Ticket Scanner (older than 2.5.4)
- Affected
- older than 2.5.4
- Fixed in
- 2.5.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Event Tickets with Ticket Scanner WordPress plugin before 2.5.4 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack
medium 5.4 CVE-2024-9866 · published 2024-12-06
Stored cross-site scripting (XSS) in Event Tickets with Ticket Scanner (2.4.3 and older)
- Affected
- 2.4.3 and older
- Fixed in
- 2.6.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Event Tickets with Ticket Scanner plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'data' parameters in all versions up to, and including, 2.4.4 due to insufficient input sanitization and output escaping and missing authorization on the functionality to manage tickets. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This missing authorization aspect of this was patched in 2.4.1, while the Cross-Site Scripting was fully patched in 2.4.4.
high 8.8 CVE-2024-52427 · published 2024-11-18
PHP object injection in Event Tickets with Ticket Scanner (2.3.11 and older)
- Affected
- 2.3.11 and older
- Fixed in
- 2.3.12
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Deserialization of Untrusted Data vulnerability in Vollstart Event Tickets with Ticket Scanner event-tickets-with-ticket-scanner allows Server Side Include (SSI) Injection.This issue affects Event Tickets with Ticket Scanner: from n/a through <= 2.3.11.
medium 6.1 CVE-2024-35652 · published 2024-06-04
Reflected cross-site scripting (XSS) in Event Tickets with Ticket Scanner (2.3.1 and older)
- Affected
- 2.3.1 and older
- Fixed in
- 2.3.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Saso Nikolov Event Tickets with Ticket Scanner allows Reflected XSS.This issue affects Event Tickets with Ticket Scanner: from n/a through 2.3.1.
Recent activity
- 2026-11-03 — latest release on wordpress.org (3.3.1).
- 2026-01-22 — Remote code execution disclosed (CVE-2025-68015), fixed in 2.8.6.
- 2025-05-15 — Cross-site scripting (XSS) disclosed (CVE-2024-6711), fixed in 2.3.8.
- 2025-03-28 — Cross-site request forgery (CSRF) disclosed (CVE-2025-1762), fixed in 2.5.4.
Get an email when Event Tickets with Ticket Scanner has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Event Tickets with Ticket Scanner (event-tickets-with-ticket-scanner) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Vollstart (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Remote code execution (1) · Cross-site request forgery (CSRF) (1) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/event-tickets-with-ticket-scanner (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/event-tickets-with-ticket-scanner"><img src="https://laskyr.com/plugins/event-tickets-with-ticket-scanner/badge.svg" alt="Event Tickets with Ticket Scanner vulnerability status"></a>