Plugins · email-template-customizer-for-woo · data as of 2026-11-04
Is Mailonix safe? Known vulnerabilities and latest version
- Latest version
- 1.3.5
- Last updated
- 2026-10-08
- Active installs
- 20,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Make your WooCommerce emails become professional. — by VillaTheme
What to do
- Update to the latest version (1.3.5). Anything older than 1.3.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get email-template-customizer-for-woo --field=version shows what you run; wp plugin update email-template-customizer-for-woo updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-103358 · published 2026-10-14
Remote code execution in Mailonix (1.3.4 and older)
- Affected
- 1.3.4 and older
- Fixed in
- 1.3.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Generation of Code ('Code Injection') vulnerability in VillaTheme Email Template Customizer for WooCommerce email-template-customizer-for-woo allows Code Injection.This issue affects Email Template Customizer for WooCommerce: from n/a through 1.3.4.
medium 5.9 CVE-2025-64200 · published 2025-10-29
Stored cross-site scripting (XSS) in Mailonix (1.2.17 and older)
- Affected
- 1.2.17 and older
- Fixed in
- 1.2.18
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VillaTheme Email Template Customizer for WooCommerce email-template-customizer-for-woo allows Stored XSS.This issue affects Email Template Customizer for WooCommerce: from n/a through <= 1.2.17.
medium 4.8 CVE-2024-49288 · published 2024-10-17
Stored cross-site scripting (XSS) in Mailonix (1.2.9.1 and older)
- Affected
- 1.2.9.1 and older
- Fixed in
- 1.2.9.2
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VillaTheme Email Template Customizer for WooCommerce email-template-customizer-for-woo allows Stored XSS.This issue affects Email Template Customizer for WooCommerce: from n/a through <= 1.2.9.1.
Recent activity
- 2026-10-08 — latest release on wordpress.org (1.3.5).
- 2026-10-14 — Remote code execution disclosed (CVE-2026-103358), fixed in 1.3.5.
- 2025-10-29 — Stored cross-site scripting (XSS) disclosed (CVE-2025-64200), fixed in 1.2.18.
- 2024-10-17 — Stored cross-site scripting (XSS) disclosed (CVE-2024-49288), fixed in 1.2.9.2.
Get an email when Mailonix has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Mailonix (email-template-customizer-for-woo) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by VillaTheme (25 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/email-template-customizer-for-woo (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/email-template-customizer-for-woo"><img src="https://laskyr.com/plugins/email-template-customizer-for-woo/badge.svg" alt="Mailonix vulnerability status"></a>