Plugins · easy-php-settings · data as of 2026-11-04
Is Easy PHP Settings safe? Known vulnerabilities and latest version
- Latest version
- 1.1.8
- Last updated
- 2026-09-02
- Active installs
- 1,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
An easy way to manage common PHP INI settings and WordPress debugging constants from the WordPress admin panel. — by shahadul878
What to do
- Update to the latest version (1.1.8). Anything older than 1.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get easy-php-settings --field=version shows what you run; wp plugin update easy-php-settings updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-3352 · published 2026-03-07
Remote code execution in Easy PHP Settings (1.0.4 and older)
- Affected
- 1.0.4 and older
- Fixed in
- 1.0.5 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Easy PHP Settings plugin for WordPress is vulnerable to PHP Code Injection in all versions up to, and including, 1.0.4 via the `update_wp_memory_constants()` method. This is due to insufficient input validation on the `wp_memory_limit` and `wp_max_memory_limit` settings before writing them to `wp-config.php`. The `sanitize_text_field()` function used for sanitization does not filter single quotes, allowing an attacker to break out of the string context in a PHP `define()` statement. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject and execute arbitrary PHP code on the server by modifying `wp-config.php`, which is loaded on every page request.
Recent activity
- 2026-09-02 — latest release on wordpress.org (1.1.8).
- 2026-03-07 — Remote code execution disclosed (CVE-2026-3352), fixed in 1.0.5.
Get an email when Easy PHP Settings has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Easy PHP Settings (easy-php-settings) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/easy-php-settings (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/easy-php-settings"><img src="https://laskyr.com/plugins/easy-php-settings/badge.svg" alt="Easy PHP Settings vulnerability status"></a>