Skip to content
Laskyr

Plugins · easy-invoice · data as of 2026-11-04

Is Easy Invoice safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.6)

As of 2026-11-04. 5 issues are on record for older versions; version 2.4.0 or newer fixes all of them that state a fix.

Latest version
2.4.6
Last updated
2026-11-01
Active installs
600+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Invoices, quotes, PDFs and payments inside WordPress. Unlimited documents, PayPal, credit notes, statements and a REST API — free. — by MatrixAddons

What to do

  1. Update to the latest version (2.4.6). Anything older than 2.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easy-invoice --field=version shows what you run; wp plugin update easy-invoice updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-66676 · published 2026-09-17

Missing authorization check in Easy Invoice (2.3.8 and older)

Affected
2.3.8 and older
Fixed in
2.4.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Easy Invoice <= 2.3.8 versions.

NVD CVE-2026-66676Patchstack advisory

medium 5.3 CVE-2026-9021 · published 2026-07-09

Missing authorization check in Easy Invoice (2.2.19 and older)

Affected
2.2.19 and older
Fixed in
2.3.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Easy Invoice plugin for WordPress is vulnerable to Missing Authorization in versions up to, and including, 2.1.19. This is due to the plugin registering the easy_invoice_accept_quote and easy_invoice_decline_quote AJAX actions via wp_ajax_nopriv_ hooks and relying solely on a quote-scoped nonce that is rendered into the publicly accessible single quote template, combined with an ownership check that is gated behind an off-by-default Pro option (easy_invoice_pro_restrict_quote_to_client). This makes it possible for unauthenticated attackers to accept or decline arbitrary published quotes — and, depending on the configured accept action, automatically convert them into invoices (and even email them to the client) — by harvesting the per-quote nonce from the public quote page and submitting it to admin-ajax.

NVD CVE-2026-9021Wordfence advisoryCode change (fix)Plugin source

critical 10.0 CVE-2026-48836 · published 2026-06-15

Remote code execution in Easy Invoice (2.1.19 and older)

Affected
2.1.19 and older
Fixed in
2.1.20
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Remote Code Execution (RCE) in Easy Invoice <= 2.1.19 versions.

NVD CVE-2026-48836Patchstack advisory

high 7.1 CVE-2025-6324 · published 2025-12-18

Cross-site scripting (XSS) in Easy Invoice (2.0.9 and older)

Affected
2.0.9 and older
Fixed in
2.1.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in MatrixAddons Easy Invoice easy-invoice allows DOM-Based XSS.This issue affects Easy Invoice: from n/a through <= 2.0.9.

NVD CVE-2025-6324Patchstack advisory

medium 6.6 CVE-2025-66115 · published 2025-11-21

File inclusion in Easy Invoice (2.1.4 and older)

Affected
2.1.4 and older
Fixed in
2.1.5
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in MatrixAddons Easy Invoice easy-invoice allows PHP Local File Inclusion.This issue affects Easy Invoice: from n/a through <= 2.1.4.

NVD CVE-2025-66115Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Easy Invoice vulnerability status badge
<a href="https://laskyr.com/plugins/easy-invoice"><img src="https://laskyr.com/plugins/easy-invoice/badge.svg" alt="Easy Invoice vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit