Skip to content
Laskyr

Plugins · creatorlms · data as of 2026-11-04

Is Creator LMS safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.23)

As of 2026-11-04. 7 issues are on record for older versions; version 1.2.22 or newer fixes all of them that state a fix.

Latest version
1.2.23
Last updated
2026-11-03
Active installs
100+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.2 · PHP 7.4+

The best free WordPress LMS plugin for coaches & course creators. Native checkout, quizzes, certificates free forever — cohort-based learning on B … — by WPFunnels

What to do

  1. Update to the latest version (1.2.23). Anything older than 1.2.22 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get creatorlms --field=version shows what you run; wp plugin update creatorlms updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.9 CVE-2026-62129 · published 2026-10-10

Arbitrary file upload in Creator LMS (1.2.21 and older)

Affected
1.2.21 and older
Fixed in
1.2.22
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Arbitrary File Upload in Creator LMS <= 1.2.21 versions.

NVD CVE-2026-62129Patchstack advisory

medium 5.3 CVE-2026-62128 · published 2026-10-08

Missing authorization check in Creator LMS (1.2.21 and older)

Affected
1.2.21 and older
Fixed in
1.2.22
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Creator LMS Creator LMS creatorlms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Creator LMS: from n/a through 1.2.21.

NVD CVE-2026-62128Patchstack advisory

high 7.5 CVE-2026-97244 · published 2026-09-30

Path traversal / file read in Creator LMS (1.2.19 and older)

Affected
1.2.19 and older
Fixed in
1.2.20
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Path Traversal in Creator LMS <= 1.2.19 versions.

NVD CVE-2026-97244Patchstack advisory

medium 5.4 CVE-2026-62083 · published 2026-09-30

Security issue in Creator LMS (1.2.19 and older)

Affected
1.2.19 and older
Fixed in
1.2.20
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Other Vulnerability Type in Creator LMS <= 1.2.19 versions.

NVD CVE-2026-62083Patchstack advisory

high 8.8 CVE-2026-32530 · published 2026-03-25

Privilege escalation in Creator LMS (1.1.18 and older)

Affected
1.1.18 and older
Fixed in
1.1.19
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in WPFunnels Creator LMS creatorlms allows Privilege Escalation.This issue affects Creator LMS: from n/a through <= 1.1.18.

NVD CVE-2026-32530Patchstack advisory

high 8.8 CVE-2025-15347 · published 2026-01-20

Privilege escalation in Creator LMS (1.1.12 and older)

Affected
1.1.12 and older
Fixed in
1.1.13 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Creator LMS – The LMS for Creators, Coaches, and Trainers plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check in the get_items_permissions_check function in all versions up to, and including, 1.1.12. This makes it possible for authenticated attackers, with contributor level access and above, to update arbitrary WordPress options.

NVD CVE-2025-15347Wordfence advisoryCode change (fix)

medium 5.3 CVE-2025-69359 · published 2026-01-06

Missing authorization check in Creator LMS (1.1.12 and older)

Affected
1.1.12 and older
Fixed in
1.1.13
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPFunnels Creator LMS creatorlms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Creator LMS: from n/a through <= 1.1.12.

NVD CVE-2025-69359Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Creator LMS vulnerability status badge
<a href="https://laskyr.com/plugins/creatorlms"><img src="https://laskyr.com/plugins/creatorlms/badge.svg" alt="Creator LMS vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit