CVE-2026-62129: Creator LMS arbitrary file upload vulnerability
critical 9.9 published 2026-10-10 · updated 2026-10-13
- Affected versions
- 1.2.21 and older
- Fixed in
- 1.2.22
- Latest version
- 1.2.23
- Severity
- Critical · CVSS 9.9
- Active installs
- 100+
- Type
- Arbitrary file upload
What an attacker needs
- Access: A low-level account on the site, such as a subscriber or customer (per the CVSS score).
CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
What to do now
- Update Creator LMS to 1.2.22 or newer (the latest is 1.2.23): Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- Not sure which version you run? Check your version against every known Creator LMS issue.
With WP-CLI:
wp plugin get creatorlms --field=version. - If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.
The advisory
Contributor Arbitrary File Upload in Creator LMS <= 1.2.21 versions.
References
- NVD CVE-2026-62129 nvd.nist.gov
- Patchstack advisory patchstack.com
Related
Ran an affected version? Check your site for signs of a hack
The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.
Where this data comes from
- CVE record, score and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Versions and install counts: wordpress.org/plugins/creatorlms (Plugins API), fetched 2026-11-04.
- The summary, “what an attacker needs” and “what to do” sections are our plain-English reading of the record and the plugin's release history; the quoted description is the record's own text. Spot an error? Email Daniel.