Skip to content
Laskyr

Plugins · cornerstone · data as of 2026-11-04

Is Cornerstone safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.8.1)

As of 2026-11-04. 7 issues are on record for older versions; version 7.8.8 or newer fixes all of them that state a fix.

Latest version
0.8.1
Last updated
2026-09-12
Active installs
20,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4

Enhanced content management for WordPress — by Archetyped

What to do

  1. Update to the latest version (0.8.1). Anything older than 7.8.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cornerstone --field=version shows what you run; wp plugin update cornerstone updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 5 record(s) do not state which versions are affected.

high 7.7 CVE-2026-9709 · published 2026-06-24

Security issue in Cornerstone (3.0.0 up to (not including) 7.8.9)

Affected
3.0.0 up to (not including) 7.8.9
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP

Note: the source's version range goes past the newest Cornerstone release on wordpress.org (0.8.1), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

The Cornerstone WordPress plugin before 7.8.9 does not enforce capability checks on one of its REST API routes, allowing any authenticated user to disclose the metadata of any other user, including roles, session token previews and stored billing/shipping fields. This affects the premium co Cornerstone page builder distributed bundled with the X , not the unrelated free `cornerstone` Cornerstone WordPress plugin before 7.8.9 (v0.8.x) on the .org repository.

NVD CVE-2026-9709WPScan advisory

high 7.7 CVE-2026-9710 · published 2026-06-24

Security issue in Cornerstone (3.0.0 up to (not including) 7.8.8)

Affected
3.0.0 up to (not including) 7.8.8
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP

Note: the source's version range goes past the newest Cornerstone release on wordpress.org (0.8.1), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

The Cornerstone WordPress plugin before 7.8.8 does not enforce capability checks on one of its CSS-preview request handlers, and exposes the nonce needed to call it to every logged-in user on any wp-admin page, allowing any authenticated user to evaluate dynamic content tokens against arbitrary users and disclose their sensitive metadata including raw password hashes. This affects the premium co Cornerstone page builder distributed bundled with the X , not the unrelated free `cornerstone` Cornerstone WordPress plugin before 7.8.8 (v0.8.x) on the .org repository.

NVD CVE-2026-9710WPScan advisory

high 8.5 CVE-2026-54185 · published 2026-06-17

SQL injection in Cornerstone (older than 7.8.8)

Affected
older than 7.8.8
Fixed in
7.8.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack

Note: the source's version range goes past the newest Cornerstone release on wordpress.org (0.8.1), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

Subscriber SQL Injection in Cornerstone < 7.8.8 versions.

NVD CVE-2026-54185Patchstack advisory

high 8.5 CVE-2026-49113 · published 2026-06-17

Remote code execution in Cornerstone (older than 7.8.8)

Affected
older than 7.8.8
Fixed in
7.8.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack

Note: the source's version range goes past the newest Cornerstone release on wordpress.org (0.8.1), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

Subscriber Arbitrary Code Execution in Cornerstone < 7.8.8 versions.

NVD CVE-2026-49113Patchstack advisory

medium 6.5 CVE-2025-63072 · published 2025-12-09

Stored cross-site scripting (XSS) in Cornerstone (7.7.3 and older)

Affected
7.7.3 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack

Note: the source's version range goes past the newest Cornerstone release on wordpress.org (0.8.1), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in THEMECO Cornerstone cornerstone allows Stored XSS.This issue affects Cornerstone: from n/a through <= 7.7.3.

NVD CVE-2025-63072Patchstack advisory

high 7.1 CVE-2024-32570 · published 2024-04-18

Reflected cross-site scripting (XSS) in Cornerstone (0.8.0 and older)

Affected
0.8.0 and older
Fixed in
0.8.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Archetyped Cornerstone allows Reflected XSS.This issue affects Cornerstone: from n/a through 0.8.0.

NVD CVE-2024-32570Patchstack advisory

high 7.1 CVE-2024-28002 · published 2024-03-28

Reflected cross-site scripting (XSS) in Cornerstone (0.8.0 and older)

Affected
0.8.0 and older
Fixed in
0.8.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Archetyped Cornerstone allows Reflected XSS.This issue affects Cornerstone: from n/a through 0.8.0.

NVD CVE-2024-28002Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Cornerstone vulnerability status badge
<a href="https://laskyr.com/plugins/cornerstone"><img src="https://laskyr.com/plugins/cornerstone/badge.svg" alt="Cornerstone vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit