Skip to content
Laskyr

Plugins · content-visibility-for-divi-builder · data as of 2026-11-04

Is Content Visibility for Divi Builder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.03)

As of 2026-11-04. 1 issue is on record for older versions; version 5.00 or newer fixes all of them that state a fix.

Latest version
5.03
Last updated
2026-10-06
Active installs
2,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

Content Visibility for Divi Builder. — by Jonathan Horowitz

What to do

  1. Update to the latest version (5.03). Anything older than 5.00 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get content-visibility-for-divi-builder --field=version shows what you run; wp plugin update content-visibility-for-divi-builder updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-1829 · published 2026-06-02

Remote code execution in Content Visibility for Divi Builder (4.02 and older)

Affected
4.02 and older
Fixed in
5.00 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Content Visibility for Divi Builder plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.02 via the 'et_pb_text' shortcode 'cvdb_content_visibility_check' parameter. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server.

NVD CVE-2026-1829Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Content Visibility for Divi Builder vulnerability status badge
<a href="https://laskyr.com/plugins/content-visibility-for-divi-builder"><img src="https://laskyr.com/plugins/content-visibility-for-divi-builder/badge.svg" alt="Content Visibility for Divi Builder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit