Skip to content
Laskyr

Plugins · contact-form-7-dynamic-text-extension · data as of 2026-11-04

Is DTX safe? Known vulnerabilities and latest version

The latest version (5.0.7) has 2 known unpatched vulnerabilities

As of 2026-11-04, the sources we check list the newest release of DTX as affected and name no fixed version yet.

Latest version
5.0.7
Last updated
2026-08-04
Active installs
100,000+
Known issues on record
7
Unpatched in latest
2
Tested up to WP
7.0.8 · PHP 7.4+

Extends Contact Form 7 by adding dynamic form fields that accepts shortcodes to prepopulate form fields with default values and dynamic placeholders. — by sevenspark

What to do

  1. There is no fixed version yet. If you can live without DTX for now, deactivate it and delete it until the developer ships a fix.
  2. If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
  3. Watch for an update: get an email when this page changes.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.

With WP-CLI: wp plugin get contact-form-7-dynamic-text-extension --field=version shows what you run; wp plugin update contact-form-7-dynamic-text-extension updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 affects latest 5.0.7 CVE-2026-62043 · published 2026-10-10

Information disclosure in DTX (5.0.7 and older)

Affected
5.0.7 and older
Fixed in
no fix listed yet
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Sensitive Data Exposure in Contact Form 7 – Dynamic Text Extension <= 5.0.7 versions.

NVD CVE-2026-62043Patchstack advisory

medium 4.4 CVE-2026-5116 · published 2026-08-05

Stored cross-site scripting (XSS) in DTX (5.0.5 and older)

Affected
5.0.5 and older
Fixed in
5.0.6 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Contact Form 7 – Dynamic Text Extension plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 5.0.5. This is due to insufficient output escaping on form shortcode keys displayed in the admin "Scan Forms for Post Meta and User Data Keys" page. This makes it possible for authenticated attackers, with Editor-level access and above, to inject arbitrary web scripts that execute when an Administrator runs the scan feature.

NVD CVE-2026-5116Wordfence advisoryCode change (fix)Plugin source

medium 6.5 affects latest 5.0.7 CVE-2025-13146 · published 2026-07-22

Remote code execution in DTX (5.0.7 and older)

Affected
5.0.7 and older
Fixed in
no fix listed yet
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The Contact Form 7 – Dynamic Text Extension plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.0.7. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. The vulnerability was partially patched in version 5.0.4.

NVD CVE-2025-13146Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2025-63068 · published 2025-12-09

Cross-site scripting (XSS) in DTX (5.0.5 and older)

Affected
5.0.5 and older
Fixed in
5.0.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in sevenspark Contact Form 7 – Dynamic Text Extension contact-form-7-dynamic-text-extension allows Code Injection.This issue affects Contact Form 7 – Dynamic Text Extension: from n/a through <= 5.0.5.

NVD CVE-2025-63068Patchstack advisory

medium 4.3 CVE-2024-56218 · published 2024-12-31

Cross-site request forgery (CSRF) in DTX (5.0.1 and older)

Affected
5.0.1 and older
Fixed in
5.0.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in sevenspark Contact Form 7 – Dynamic Text Extension contact-form-7-dynamic-text-extension allows Cross Site Request Forgery.This issue affects Contact Form 7 – Dynamic Text Extension: from n/a through <= 5.0.1.

NVD CVE-2024-56218Patchstack advisory

medium 4.3 CVE-2024-10084 · published 2024-11-05

Information disclosure in DTX (4.5 and older)

Affected
4.5 and older
Fixed in
4.5.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Contact Form 7 – Dynamic Text Extension plugin for WordPress is vulnerable to Basic Information Disclosure in all versions up to, and including, 4.5 via the CF7_get_post_var shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract the titles and text contents of private and password-protected posts, they do not own.

NVD CVE-2024-10084Wordfence advisoryPlugin source

medium 4.3 CVE-2023-6630 · published 2024-01-11

Missing authorization check in DTX (4.1.0 and older)

Affected
4.1.0 and older
Fixed in
4.2.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Contact Form 7 – Dynamic Text Extension plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 4.1.0 via the CF7_get_custom_field and CF7_get_current_user shortcodes due to missing validation on a user controlled key. This makes it possible for authenticated attackers with contributor access or higher to access arbitrary metadata of any post type, referencing the post by id and the meta by key.

NVD CVE-2023-6630Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
DTX vulnerability status badge
<a href="https://laskyr.com/plugins/contact-form-7-dynamic-text-extension"><img src="https://laskyr.com/plugins/contact-form-7-dynamic-text-extension/badge.svg" alt="DTX vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit