Plugins · checkout-files-upload-woocommerce · data as of 2026-11-04
Is Checkout Files Upload for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 2.4.0
- Last updated
- 2026-10-21
- Active installs
- 7,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Let your customers upload files on (or after) WooCommerce checkout. — by WP Wham
What to do
- Update to the latest version (2.4.0). Anything older than 2.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get checkout-files-upload-woocommerce --field=version shows what you run; wp plugin update checkout-files-upload-woocommerce updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.8 CVE-2026-103688 · published 2026-10-28
Remote code execution in Checkout Files Upload for WooCommerce (older than 2.4.0)
- Affected
- older than 2.4.0
- Fixed in
- 2.4.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Checkout Files Upload for WooCommerce WordPress plugin before 2.4.0 does not validate uploaded file types when its accepted file types setting is left empty, which it documents as the way to accept all files, allowing unauthenticated users to upload arbitrary files, including PHP files that lead to remote code execution on servers that execute PHP from the uploads directory.
medium 6.5 CVE-2026-42725 · published 2026-05-27
Missing authorization check in Checkout Files Upload for WooCommerce (2.2.5 and older)
- Affected
- 2.2.5 and older
- Fixed in
- 2.2.6
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authorization Bypass Through User-Controlled Key vulnerability in WP Wham Checkout Files Upload for WooCommerce checkout-files-upload-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Checkout Files Upload for WooCommerce: from n/a through <= 2.2.5.
high 7.2 CVE-2025-4212 · published 2025-11-18
Stored cross-site scripting (XSS) in Checkout Files Upload for WooCommerce (2.2.1 and older)
- Affected
- 2.2.1 and older
- Fixed in
- 2.2.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Checkout Files Upload for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via file uploads in all versions up to, and including, 2.2.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in image files that will execute whenever a user accesses the injected page.
medium 6.5 CVE-2025-39520 · published 2025-04-16
Stored cross-site scripting (XSS) in Checkout Files Upload for WooCommerce (2.2.0 and older)
- Affected
- 2.2.0 and older
- Fixed in
- 2.2.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Wham Checkout Files Upload for WooCommerce checkout-files-upload-woocommerce allows Stored XSS.This issue affects Checkout Files Upload for WooCommerce: from n/a through <= 2.2.0.
medium 6.1 CVE-2022-29425 · published 2022-05-20
Cross-site scripting (XSS) in Checkout Files Upload for WooCommerce (2.1.2 and older)
- Affected
- 2.1.2 and older
- Fixed in
- 2.1.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Scripting (XSS) vulnerability in WP Wham's Checkout Files Upload for WooCommerce plugin <= 2.1.2 at WordPress.
Recent activity
- 2026-10-21 — latest release on wordpress.org (2.4.0).
- 2026-10-28 — Remote code execution disclosed (CVE-2026-103688), fixed in 2.4.0.
- 2026-05-27 — Missing authorization check disclosed (CVE-2026-42725), fixed in 2.2.6.
- 2025-11-18 — Stored cross-site scripting (XSS) disclosed (CVE-2025-4212), fixed in 2.2.2.
Get an email when Checkout Files Upload for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Checkout Files Upload for WooCommerce (checkout-files-upload-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Remote code execution (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/checkout-files-upload-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/checkout-files-upload-woocommerce"><img src="https://laskyr.com/plugins/checkout-files-upload-woocommerce/badge.svg" alt="Checkout Files Upload for WooCommerce vulnerability status"></a>