Skip to content
Laskyr

Plugins · checkout-custom-fields-builder-for-woocommerce · data as of 2026-11-04

Is Checkout Custom Fields Builder for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.6)

As of 2026-11-04. 1 issue is on record for older versions; version 1.1.6 or newer fixes all of them that state a fix.

Latest version
1.1.6
Last updated
2026-09-03
Active installs
30+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Customize the WooCommerce checkout: add, remove, or edit fields to create a simple, personalized experience for your store. ----- — by Stylemix

What to do

  1. Update to the latest version (1.1.6). Anything older than 1.1.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get checkout-custom-fields-builder-for-woocommerce --field=version shows what you run; wp plugin update checkout-custom-fields-builder-for-woocommerce updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-19802 · published 2026-09-09

Remote code execution in Checkout Custom Fields Builder for WooCommerce (1.1.5 and older)

Affected
1.1.5 and older
Fixed in
1.1.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Checkout Custom Fields Builder for WooCommerce plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.1.5. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to install and activate an arbitrary attacker-hosted plugin, resulting in remote code execution on the server. The required nonce is emitted inline on all admin pages accessible to subscribers when WooCommerce is inactive, meaning any subscriber-level user can harvest it and trigger the exploit without any additional privileges.

NVD CVE-2026-19802Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Checkout Custom Fields Builder for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/checkout-custom-fields-builder-for-woocommerce"><img src="https://laskyr.com/plugins/checkout-custom-fields-builder-for-woocommerce/badge.svg" alt="Checkout Custom Fields Builder for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit