Plugins · cf-images · data as of 2026-11-04
Is Offload, AI & Optimize with Cloudflare Images safe? Known vulnerabilities and latest version
- Latest version
- 1.10.3
- Last updated
- 2026-06-07
- Active installs
- 1,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.0+
Offload you media library images to the Cloudflare Images service. Store, resize, optimize and deliver images in a fast and secure manner. — by Anton Vanyukov
What to do
- Update to the latest version (1.10.3). Anything older than 1.10.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get cf-images --field=version shows what you run; wp plugin update cf-images updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-9860 · published 2026-06-18
Remote code execution in Offload, AI & Optimize with Cloudflare Images (1.10.2 and older)
- Affected
- 1.10.2 and older
- Fixed in
- 1.10.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Offload, AI & Optimize with Cloudflare Images plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.10.2 via the 'account-id' parameter parameter. This is due to insufficient privilege enforcement on the cf_images_do_setup AJAX handler, which requires only the upload_files capability (Author+) rather than manage_options before writing to wp-config.php, combined with the absence of single-quote escaping — sanitize_text_field() does not strip single quotes, and filter_input(INPUT_POST) bypasses wp_magic_quotes() slashing — allowing a single quote in the account-id or api-key parameter to break out of the single-quoted PHP string literal in the write_config() define() statement. This makes it possible for authenticated attackers, with author-level access and above, to execute code on the server. This is possible because the 'cf-images-nonce' nonce required by the AJAX handler is exposed to all Author-level and above users on wp-admin/upload.php via the CFImages JavaScript object, meaning any upload-capable user can satisfy the nonce check and reach the vulnerable wp-config.php write path.
NVD CVE-2026-9860Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-66104 · published 2025-12-18
Missing authorization check in Offload, AI & Optimize with Cloudflare Images (1.9.5 and older)
- Affected
- 1.9.5 and older
- Fixed in
- 1.9.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Anton Vanyukov Offload, AI & Optimize with Cloudflare Images cf-images allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Offload, AI & Optimize with Cloudflare Images: from n/a through <= 1.9.5.
Recent activity
- 2026-06-07 — latest release on wordpress.org (1.10.3).
- 2026-06-18 — Remote code execution disclosed (CVE-2026-9860), fixed in 1.10.3.
- 2025-12-18 — Missing authorization check disclosed (CVE-2025-66104), fixed in 1.9.6.
Get an email when Offload, AI & Optimize with Cloudflare Images has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Offload, AI & Optimize with Cloudflare Images (cf-images) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Remote code execution (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/cf-images (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/cf-images"><img src="https://laskyr.com/plugins/cf-images/badge.svg" alt="Offload, AI & Optimize with Cloudflare Images vulnerability status"></a>