Skip to content
Laskyr

Plugins · cartflows · data as of 2026-11-04

Is CartFlows safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3.1)

As of 2026-11-04. 7 issues are on record for older versions; version 3.2.1 or newer fixes all of them that state a fix.

Latest version
3.3.1
Last updated
2026-11-02
Active installs
200,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

1 WordPress funnel builder & WooCommerce checkout plugin. Boost AOV with one-click upsells, order bumps & high-converting checkout pages. — by Brainstorm Force

What to do

  1. Update to the latest version (3.3.1). Anything older than 3.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cartflows --field=version shows what you run; wp plugin update cartflows updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-96837 · published 2026-09-30

Remote code execution in CartFlows (3.2.0 and older)

Affected
3.2.0 and older
Fixed in
3.2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Remote Code Execution (RCE) in CartFlows <= 3.2.0 versions.

NVD CVE-2026-96837Patchstack advisory

medium 4.3 CVE-2026-39477 · published 2026-04-08

Missing authorization check in CartFlows (2.2.3 and older)

Affected
2.2.3 and older
Fixed in
2.2.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Brainstorm Force CartFlows cartflows allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CartFlows: from n/a through <= 2.2.3.

NVD CVE-2026-39477Patchstack advisory

high 7.2 CVE-2026-25316 · published 2026-02-19

PHP object injection in CartFlows (2.1.19 and older)

Affected
2.1.19 and older
Fixed in
2.2.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Brainstorm Force CartFlows cartflows allows Object Injection.This issue affects CartFlows: from n/a through <= 2.1.19.

NVD CVE-2026-25316Patchstack advisory

medium 6.4 CVE-2024-4632 · published 2024-06-19

Stored cross-site scripting (XSS) in CartFlows (2.0.7 and older)

Affected
2.0.7 and older
Fixed in
2.0.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WooCommerce Checkout & Funnel Builder by CartFlows – Create High Converting Stores For WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘custom_upload_mimes’ function in versions up to, and including, 2.0.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-4632Wordfence advisoryCode change (fix)Plugin source

medium 5.9 CVE-2024-29813 · published 2024-03-27

Stored cross-site scripting (XSS) in CartFlows (2.0.1 and older)

Affected
2.0.1 and older
Fixed in
2.0.2
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CartFlows Inc. Funnel Builder by CartFlows allows Stored XSS.This issue affects Funnel Builder by CartFlows: from n/a through 2.0.1.

NVD CVE-2024-29813Patchstack advisory

medium 4.3 CVE-2020-36736 · published 2023-07-01

Cross-site request forgery (CSRF) in CartFlows (older than 1.5.16)

Affected
older than 1.5.16
Fixed in
1.5.16
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WooCommerce Checkout & Funnel Builder by CartFlows plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.5.15. This is due to missing or incorrect nonce validation on the export_json, import_json, and status_logs_file functions. This makes it possible for unauthenticated attackers to import/export settings and trigger logs showing via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2020-36736Wordfence advisoryCode change (fix)blog.nintechnet.comblog.nintechnet.comblog.nintechnet.comblog.nintechnet.com

medium 4.3 CVE-2019-25151 · published 2023-06-07

Missing authorization check in CartFlows (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Funnel Builder plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the activate_plugin function in versions up to, and including, 1.3.0. This makes it possible for authenticated attackers to activate any plugin on the vulnerable service.

NVD CVE-2019-25151Wordfence advisoryWPScan advisoryblog.nintechnet.comacunetix.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CartFlows vulnerability status badge
<a href="https://laskyr.com/plugins/cartflows"><img src="https://laskyr.com/plugins/cartflows/badge.svg" alt="CartFlows vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit