Plugins · bp-profile-search · data as of 2026-11-04
Is BP Profile Search safe? Known vulnerabilities and latest version
- Latest version
- 6.0
- Last updated
- 2026-10-10
- Active installs
- 5,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Member search and member directories for BuddyPress and the BuddyBoss Platform. — by Andrea Tarantini
What to do
- Update to the latest version (6.0). Anything older than 6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get bp-profile-search --field=version shows what you run; wp plugin update bp-profile-search updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.1 CVE-2026-104995 · published 2026-10-14
Remote code execution in BP Profile Search (5.9 and older)
- Affected
- 5.9 and older
- Fixed in
- 6.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The BP Profile Search plugin for WordPress is vulnerable to Local File Inclusion in versions up to, and including, 5.9 via the 'ajax_template' value parsed from the client-controlled 'bps_directory' cookie during BuddyPress AJAX directory requests. The bps_directory_ajax() filter (hooked onto bp_legacy_object_template_path and bp_nouveau_object_template_path) reads the cookie, applies only a referer-derived 'page' comparison in bps_get_directory_data() (where bps_current_page() uses HTTP_REFERER during AJAX and is therefore also attacker-controlled), and then suffixes the attacker-controlled template value with '.php' and passes it to bp_locate_template() with no basename restriction, no whitelist, and no path-traversal check. This makes it possible for unauthenticated attackers to include arbitrary PHP files on the server, which can lead to remote code execution when PHP files can be uploaded or when images such as the default wordpress:php8.
NVD CVE-2026-104995Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2024-7850 · published 2024-08-20
Cross-site request forgery (CSRF) in BP Profile Search (5.7.5 and older)
- Affected
- 5.7.5 and older
- Fixed in
- 5.8 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The BP Profile Search plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.7.5. This is due to missing or incorrect nonce validation on the bps_ajax_field_selector(), bps_ajax_template_options(), and bps_ajax_field_row() functions. This makes it possible for unauthenticated attackers to inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2024-7850Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2024-22293 · published 2024-01-31
Reflected cross-site scripting (XSS) in BP Profile Search (5.5 and older)
- Affected
- 5.5 and older
- Fixed in
- 5.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Andrea Tarantini BP Profile Search allows Reflected XSS.This issue affects BP Profile Search: from n/a through 5.5.
Recent activity
- 2026-10-10 — latest release on wordpress.org (6.0).
- 2026-10-14 — Remote code execution disclosed (CVE-2026-104995), fixed in 6.0.
- 2024-08-20 — Cross-site request forgery (CSRF) disclosed (CVE-2024-7850), fixed in 5.8.
- 2024-01-31 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-22293), fixed in 5.6.
Get an email when BP Profile Search has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for BP Profile Search (bp-profile-search) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Remote code execution (1) · Cross-site request forgery (CSRF) (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/bp-profile-search (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/bp-profile-search"><img src="https://laskyr.com/plugins/bp-profile-search/badge.svg" alt="BP Profile Search vulnerability status"></a>