Skip to content
Laskyr

Plugins · b-slider · data as of 2026-11-04

Is bSlider safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.5)

As of 2026-11-04. 8 issues are on record for older versions; version 2.2.4 or newer fixes all of them that state a fix.

Latest version
2.2.5
Last updated
2026-11-04
Active installs
5,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Responsive sliders from images, posts, WooCommerce, videos or blocks — or start from 50+ ready-made templates. Block editor & shortcode. — by bPlugins

What to do

  1. Update to the latest version (2.2.5). Anything older than 2.2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get b-slider --field=version shows what you run; wp plugin update b-slider updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-115961 · published 2026-10-26

Stored cross-site scripting (XSS) in bSlider (2.2.2 and older)

Affected
2.2.2 and older
Fixed in
2.2.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins B Slider b-slider allows Stored XSS.This issue affects B Slider: from n/a through 2.2.2.

NVD CVE-2026-115961Patchstack advisory

medium 6.5 CVE-2026-24383 · published 2026-01-22

Cross-site scripting (XSS) in bSlider (2.0.6 and older)

Affected
2.0.6 and older
Fixed in
2.0.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins B Slider b-slider allows DOM-Based XSS.This issue affects B Slider: from n/a through <= 2.0.6.

NVD CVE-2026-24383Patchstack advisory

medium 5.8 CVE-2025-54734 · published 2025-08-28

Missing authorization check in bSlider (1.1.30 and older)

Affected
1.1.30 and older
Fixed in
2.0.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in bPlugins B Slider b-slider allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects B Slider: from n/a through <= 1.1.30.

NVD CVE-2025-54734Patchstack advisory

medium 4.3 CVE-2025-8676 · published 2025-08-15

Information disclosure in bSlider (2.0.0 and older)

Affected
2.0.0 and older
Fixed in
2.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The B Slider- Gutenberg Slider Block for WP plugin for WordPress is vulnerable to Sensitive Information Exposure in versions less than, or equal to, 2.0.0 via the get_active_plugins function. This makes it possible for authenticated attackers, with subscriber-level access and above to extract sensitive data including installed plugin information.

NVD CVE-2025-8676Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-8680 · published 2025-08-15

Server-side request forgery (SSRF) in bSlider (2.0.0 and older)

Affected
2.0.0 and older
Fixed in
2.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The B Slider- Gutenberg Slider Block for WP plugin for WordPress is vulnerable to Server-Side Request Forgery in version less than, or equal to, 2.0.0 via the fs_api_request function. This makes it possible for authenticated attackers, with subscriber-level access and above to make web requests to arbitrary locations originating from the web application which can be used to query and modify information from internal services.

NVD CVE-2025-8680Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2025-8418 · published 2025-08-12

Remote code execution in bSlider (1.1.30 and older)

Affected
1.1.30 and older
Fixed in
2.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The B Slider- Gutenberg Slider Block for WP plugin for WordPress is vulnerable to Arbitrary Plugin Installation in all versions up to, and including, 1.1.30. This is due to missing capability checks on the activated_plugin function. This makes it possible for authenticated attackers, with subscriber-level access and above, to install arbitrary plugins on the server which can make remote code execution possible.

NVD CVE-2025-8418Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2024-13514 · published 2025-02-04

Information disclosure in bSlider (1.1.23 and older)

Affected
1.1.23 and older
Fixed in
1.1.24 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The B Slider- Gutenberg Slider Block for WP plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.9.5 via the 'bsb-slider' shortcode due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from private posts that they should not have access to.

NVD CVE-2024-13514Wordfence advisoryCode change (fix)

medium 6.5 CVE-2024-30432 · published 2024-03-29

Stored cross-site scripting (XSS) in bSlider (1.1.12 and older)

Affected
1.1.12 and older
Fixed in
1.1.13
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins B Slider - Slider for your block editor allows Stored XSS.This issue affects B Slider - Slider for your block editor: from n/a through 1.1.12.

NVD CVE-2024-30432Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
bSlider vulnerability status badge
<a href="https://laskyr.com/plugins/b-slider"><img src="https://laskyr.com/plugins/b-slider/badge.svg" alt="bSlider vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit