Plugins · authors-list · data as of 2026-11-04
Is Authors List safe? Known vulnerabilities and latest version
- Latest version
- 2.0.6.2
- Last updated
- 2025-11-24
- Active installs
- 5,000+
- Known issues on record
- 5
- Unpatched in latest
- 1
- Tested up to WP
- 6.8.12 · PHP 5.4+
Use a shortcode to display a list or grid of post authors (or any other user role) and links to their post archives page. — by WPKube
What to do
- There is no fixed version yet. If you can live without Authors List for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get authors-list --field=version shows what you run; wp plugin update authors-list updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2025-12010 · published 2025-11-11
Information disclosure in Authors List (2.0.6.1 and older)
- Affected
- 2.0.6.1 and older
- Fixed in
- 2.0.6.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Authors List plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.0.6.1 via the via arbitrary method call from Authors_List_Shortcode class. This makes it possible for authenticated attackers, with Contributor-level access and above, to call methods such as get_meta to extract sensitive user data including password hashes, email addresses, usernames, and activation keys via specially crafted shortcode attributes
medium 4.3 affects latest 2.0.6.2 CVE-2025-58792 · published 2025-09-05
Cross-site request forgery (CSRF) in Authors List (2.0.6.2 and older)
- Affected
- 2.0.6.2 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in WPKube Authors List authors-list allows Cross Site Request Forgery.This issue affects Authors List: from n/a through <= 2.0.6.2.
medium 6.5 CVE-2024-13806 · published 2025-03-01
Remote code execution in Authors List (2.0.6 and older)
- Affected
- 2.0.6 and older
- Fixed in
- 2.0.6.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The The Authors List plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.0.6. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
high 7.3 CVE-2024-10952 · published 2024-12-04
Remote code execution in Authors List (2.0.4 and older)
- Affected
- 2.0.4 and older
- Fixed in
- 2.0.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The The Authors List plugin for WordPress is vulnerable to arbitrary shortcode execution via update_authors_list_ajax AJAX action in all versions up to, and including, 2.0.4. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
NVD CVE-2024-10952Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 6.1 CVE-2023-37981 · published 2023-07-27
Reflected cross-site scripting (XSS) in Authors List (2.0.2 and older)
- Affected
- 2.0.2 and older
- Fixed in
- 2.0.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in WPKube Authors List plugin <= 2.0.2 versions.
Recent activity
- 2025-11-24 — latest release on wordpress.org (2.0.6.2).
- 2025-11-11 — Information disclosure disclosed (CVE-2025-12010), fixed in 2.0.6.2.
- 2025-09-05 — Cross-site request forgery (CSRF) disclosed (CVE-2025-58792), no fix listed yet.
- 2025-03-01 — Remote code execution disclosed (CVE-2024-13806), fixed in 2.0.6.1.
Get an email when Authors List has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Authors List (authors-list) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WPKube (2 tracked)
Types found in this plugin: Remote code execution (2) · Sensitive data exposure (1) · Cross-site request forgery (CSRF) (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/authors-list (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/authors-list"><img src="https://laskyr.com/plugins/authors-list/badge.svg" alt="Authors List vulnerability status"></a>