Plugins · amazonsimpleadmin · data as of 2026-11-04
Is Affiliate Super Assistent safe? Known vulnerabilities and latest version
- Latest version
- 1.10.3
- Last updated
- 2026-08-30
- Active installs
- 1,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 8.1+
The flexible plugin for WordPress affiliates working with Amazon. Create your own templates, embed products by use of [asa]ASIN[/asa] shortcodes — by Timo Reith
What to do
- Update to the latest version (1.10.3). Anything older than 1.10.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get amazonsimpleadmin --field=version shows what you run; wp plugin update amazonsimpleadmin updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-19573 · published 2026-09-01
Stored cross-site scripting (XSS) in Affiliate Super Assistent (1.10.2 and older)
- Affected
- 1.10.2 and older
- Fixed in
- 1.10.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Affiliate Super Assistent plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘doCommentShortcode’ function in all versions up to, and including, 1.10.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-19573Wordfence advisoryCode change (fix)Plugin source
high 7.1 CVE-2026-42759 · published 2026-05-27
Stored cross-site scripting (XSS) in Affiliate Super Assistent (1.10.1 and older)
- Affected
- 1.10.1 and older
- Fixed in
- 1.10.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Timo Affiliate Super Assistent amazonsimpleadmin allows Stored XSS.This issue affects Affiliate Super Assistent: from n/a through <= 1.10.1.
high 7.3 CVE-2024-8478 · published 2024-09-10
Remote code execution in Affiliate Super Assistent (1.5.3 and older)
- Affected
- 1.5.3 and older
- Fixed in
- 1.5.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The The Affiliate Super Assistent plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 1.5.3. This is due to the software allowing users to supply arbitrary shortcodes in comments when the 'Parse comments' option is enabled. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
NVD CVE-2024-8478Wordfence advisoryCode change (fix)Plugin source
high 8.8 CVE-2023-27417 · published 2023-11-12
Cross-site request forgery (CSRF) in Affiliate Super Assistent (1.5.1 and older)
- Affected
- 1.5.1 and older
- Fixed in
- 1.5.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Timo Reith Affiliate Super Assistent plugin <= 1.5.1 versions.
Recent activity
- 2026-08-30 — latest release on wordpress.org (1.10.3).
- 2026-09-01 — Stored cross-site scripting (XSS) disclosed (CVE-2026-19573), fixed in 1.10.3.
- 2026-05-27 — Stored cross-site scripting (XSS) disclosed (CVE-2026-42759), fixed in 1.10.2.
- 2024-09-10 — Remote code execution disclosed (CVE-2024-8478), fixed in 1.5.4.
Get an email when Affiliate Super Assistent has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Affiliate Super Assistent (amazonsimpleadmin) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Remote code execution (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/amazonsimpleadmin (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/amazonsimpleadmin"><img src="https://laskyr.com/plugins/amazonsimpleadmin/badge.svg" alt="Affiliate Super Assistent vulnerability status"></a>