Plugins · album-and-image-gallery-plus-lightbox · data as of 2026-11-04
Is Album and Image Gallery Plus Lightbox safe? Known vulnerabilities and latest version
- Status
- Closed 2026-04-07
- Known issues on record
- 3
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate album-and-image-gallery-plus-lightbox && wp plugin delete album-and-image-gallery-plus-lightbox
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 3 record(s) do not state which versions are affected.
medium 6.4 CVE-2025-13612 · published 2026-02-19
Stored cross-site scripting (XSS) in Album and Image Gallery Plus Lightbox (2.1.7 and older)
- Affected
- 2.1.7 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Album and Image Gallery plus Lightbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `aigpl-gallery-album` shortcode in all versions up to, and including, 2.1.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-13612Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2023-25060 · published 2024-12-09
Missing authorization check in Album and Image Gallery Plus Lightbox (1.6.2 and older)
- Affected
- 1.6.2 and older
- Fixed in
- 1.6.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WP OnlineSupport, Essential Plugin Album and Image Gallery plus Lightbox allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Album and Image Gallery plus Lightbox: from n/a through 1.6.2.
high 7.3 CVE-2024-4194 · published 2024-06-06
Remote code execution in Album and Image Gallery Plus Lightbox (2.0 and older)
- Affected
- 2.0 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The The Album and Image Gallery plus Lightbox plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.0. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
NVD CVE-2024-4194Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-04-07 — closed on wordpress.org (Security Issue).
- 2026-02-19 — Stored cross-site scripting (XSS) disclosed (CVE-2025-13612), fix version not stated.
- 2024-12-09 — Missing authorization check disclosed (CVE-2023-25060), fixed in 1.6.3.
- 2024-06-06 — Remote code execution disclosed (CVE-2024-4194), fix version not stated.
Get an email when Album and Image Gallery Plus Lightbox has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Album and Image Gallery Plus Lightbox (album-and-image-gallery-plus-lightbox) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1) · Remote code execution (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/album-and-image-gallery-plus-lightbox (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/album-and-image-gallery-plus-lightbox"><img src="https://laskyr.com/plugins/album-and-image-gallery-plus-lightbox/badge.svg" alt="Album and Image Gallery Plus Lightbox vulnerability status"></a>