Plugins · advanced-woo-labels · data as of 2026-11-04
Is Advanced Woo Labels safe? Known vulnerabilities and latest version
- Latest version
- 2.55
- Last updated
- 2026-11-02
- Active installs
- 10,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Labels plugin for WooCommerce. Create labels/badges with custom styles and text for any of your WooCommerce products. — by ILLID
What to do
- Update to the latest version (2.55). Anything older than 2.52 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get advanced-woo-labels --field=version shows what you run; wp plugin update advanced-woo-labels updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-12241 · published 2026-10-01
Cross-site scripting (XSS) in Advanced Woo Labels (2.51 and older)
- Affected
- 2.51 and older
- Fixed in
- 2.52 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Advanced Woo Labels – Product Labels & Badges for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to an improperly secure capability check on the 'save_meta_boxes' function in all versions up to, and including, 2.51. This makes it possible for authenticated attackers, with Contributor-level access and above, to create AWS labels that are rendered without proper escaping. The vulnerability was partially patched in version 2.46.
NVD CVE-2026-12241Wordfence advisorykramakit.comPlugin source
medium 6.4 CVE-2026-15662 · published 2026-08-01
Stored cross-site scripting (XSS) in Advanced Woo Labels (2.48 and older)
- Affected
- 2.48 and older
- Fixed in
- 2.49 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Advanced Woo Labels – Product Labels & Badges for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'bg_color' parameter in all versions up to, and including, 2.48 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-15662Wordfence advisoryCode change (fix)Plugin source
high 7.2 CVE-2026-32414 · published 2026-03-13
Remote code execution in Advanced Woo Labels (2.36 and older)
- Affected
- 2.36 and older
- Fixed in
- 2.37
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Generation of Code ('Code Injection') vulnerability in ILLID Advanced Woo Labels advanced-woo-labels allows Remote Code Inclusion.This issue affects Advanced Woo Labels: from n/a through <= 2.36.
high 8.8 CVE-2026-1929 · published 2026-02-25
Remote code execution in Advanced Woo Labels (2.36 and older)
- Affected
- 2.36 and older
- Fixed in
- 2.37 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Advanced Woo Labels plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 2.37. This is due to the use of `call_user_func_array()` with user-controlled callback and parameters in the `get_select_option_values()` AJAX handler without an allowlist of permitted callbacks or a capability check. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute arbitrary PHP functions and operating system commands on the server via the 'callback' parameter.
medium 6.5 CVE-2025-32188 · published 2025-04-04
Stored cross-site scripting (XSS) in Advanced Woo Labels (2.15 and older)
- Affected
- 2.15 and older
- Fixed in
- 2.16
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ILLID Advanced Woo Labels advanced-woo-labels allows Stored XSS.This issue affects Advanced Woo Labels: from n/a through <= 2.15.
medium 6.5 CVE-2024-47622 · published 2024-10-05
Stored cross-site scripting (XSS) in Advanced Woo Labels (2.01 and older)
- Affected
- 2.01 and older
- Fixed in
- 2.02
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ILLID Advanced Woo Labels advanced-woo-labels allows Stored XSS.This issue affects Advanced Woo Labels: from n/a through <= 2.01.
medium 5.4 CVE-2024-35675 · published 2024-06-08
Cross-site scripting (XSS) in Advanced Woo Labels (1.93 and older)
- Affected
- 1.93 and older
- Fixed in
- 1.94
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in ILLID Advanced Woo Labels allows Cross-Site Scripting (XSS).This issue affects Advanced Woo Labels: from n/a through 1.93.
Recent activity
- 2026-11-02 — latest release on wordpress.org (2.55).
- 2026-10-01 — Cross-site scripting (XSS) disclosed (CVE-2026-12241), fixed in 2.52.
- 2026-08-01 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15662), fixed in 2.49.
- 2026-03-13 — Remote code execution disclosed (CVE-2026-32414), fixed in 2.37.
Get an email when Advanced Woo Labels has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Advanced Woo Labels (advanced-woo-labels) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by ILLID (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (5) · Remote code execution (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/advanced-woo-labels (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/advanced-woo-labels"><img src="https://laskyr.com/plugins/advanced-woo-labels/badge.svg" alt="Advanced Woo Labels vulnerability status"></a>