Plugins · add-custom-codes · data as of 2026-11-04
Is Add Custom Codes safe? Known vulnerabilities and latest version
- Latest version
- 5.0
- Last updated
- 2026-05-22
- Active installs
- 1,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
A completely free plugin to add Custom PHP functions, HTML, CSS, Javascript, any other custom codes to your wordpress website. — by SaifuMak
What to do
- Update to the latest version (5.0). Anything older than 5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get add-custom-codes --field=version shows what you run; wp plugin update add-custom-codes updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2025-62108 · published 2025-12-31
Missing authorization check in Add Custom Codes (4.80 and older)
- Affected
- 4.80 and older
- Fixed in
- 5.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in SaifuMak Add Custom Codes add-custom-codes allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Add Custom Codes: from n/a through <= 4.80.
medium 5.9 CVE-2025-62149 · published 2025-12-31
Stored cross-site scripting (XSS) in Add Custom Codes (4.80 and older)
- Affected
- 4.80 and older
- Fixed in
- 5.0
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SaifuMak Add Custom Codes add-custom-codes allows Stored XSS.This issue affects Add Custom Codes: from n/a through <= 4.80.
medium 6.5 CVE-2025-62739 · published 2025-12-09
Cross-site request forgery (CSRF) in Add Custom Codes (4.80 and older)
- Affected
- 4.80 and older
- Fixed in
- 5.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in SaifuMak Add Custom Codes add-custom-codes allows Cross Site Request Forgery.This issue affects Add Custom Codes: from n/a through <= 4.80.
high 7.5 CVE-2025-30975 · published 2025-08-20
Remote code execution in Add Custom Codes (4.80 and older)
- Affected
- 4.80 and older
- Fixed in
- 5.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Generation of Code ('Code Injection') vulnerability in SaifuMak Add Custom Codes add-custom-codes allows Code Injection.This issue affects Add Custom Codes: from n/a through <= 4.80.
Recent activity
- 2026-05-22 — latest release on wordpress.org (5.0).
- 2025-12-31 — Missing authorization check disclosed (CVE-2025-62108), fixed in 5.0.
- 2025-12-31 — Stored cross-site scripting (XSS) disclosed (CVE-2025-62149), fixed in 5.0.
- 2025-12-09 — Cross-site request forgery (CSRF) disclosed (CVE-2025-62739), fixed in 5.0.
Get an email when Add Custom Codes has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Add Custom Codes (add-custom-codes) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1) · Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/add-custom-codes (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/add-custom-codes"><img src="https://laskyr.com/plugins/add-custom-codes/badge.svg" alt="Add Custom Codes vulnerability status"></a>