Plugins · aco-woo-dynamic-pricing · data as of 2026-11-04
Is Dynamic Pricing With Discount Rules for WooCom… safe? Known vulnerabilities and latest version
- Latest version
- 5.1.1
- Last updated
- 2026-11-03
- Active installs
- 5,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.2 · PHP 7.4+
The Dynamic Pricing With Discount Rules plugin enables bulk discounts for WooCommerce products. Its simple design allows easy setup in minutes. — by acowebs
What to do
- Update to the latest version (5.1.1). Anything older than 5.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get aco-woo-dynamic-pricing --field=version shows what you run; wp plugin update aco-woo-dynamic-pricing updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-13725 · published 2026-08-01
Reflected cross-site scripting (XSS) in Dynamic Pricing With Discount Rules for WooCom… (older than 5.0.0)
- Affected
- older than 5.0.0
- Fixed in
- 5.0.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Dynamic Pricing With Discount Rules for WooCommerce WordPress plugin before 5.0.0 does not validate a nonce or user capabilities on one of its AJAX actions and reflects unsanitised user input in the response, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting against a victim who is induced to send a crafted request.
high 7.1 CVE-2026-59556 · published 2026-07-27
Cross-site scripting (XSS) in Dynamic Pricing With Discount Rules for WooCom… (4.5.11 and older)
- Affected
- 4.5.11 and older
- Fixed in
- 5.0.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Dynamic Pricing With Discount Rules for WooCommerce <= 4.5.11 versions.
critical 9.1 CVE-2025-47588 · published 2025-11-06
Remote code execution in Dynamic Pricing With Discount Rules for WooCom… (4.5.9 and older)
- Affected
- 4.5.9 and older
- Fixed in
- 4.5.10
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Generation of Code ('Code Injection') vulnerability in acowebs Dynamic Pricing With Discount Rules for WooCommerce aco-woo-dynamic-pricing allows Code Injection.This issue affects Dynamic Pricing With Discount Rules for WooCommerce: from n/a through <= 4.5.9.
high 7.2 CVE-2025-47544 · published 2025-05-07
SQL injection in Dynamic Pricing With Discount Rules for WooCom… (4.5.8 and older)
- Affected
- 4.5.8 and older
- Fixed in
- 4.5.9
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in acowebs Dynamic Pricing With Discount Rules for WooCommerce aco-woo-dynamic-pricing allows Blind SQL Injection.This issue affects Dynamic Pricing With Discount Rules for WooCommerce: from n/a through <= 4.5.8.
Recent activity
- 2026-11-03 — latest release on wordpress.org (5.1.1).
- 2026-08-01 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-13725), fixed in 5.0.0.
- 2026-07-27 — Cross-site scripting (XSS) disclosed (CVE-2026-59556), fixed in 5.0.0.
- 2025-11-06 — Remote code execution disclosed (CVE-2025-47588), fixed in 4.5.10.
Get an email when Dynamic Pricing With Discount Rules for WooCom… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Dynamic Pricing With Discount Rules for WooCom… (aco-woo-dynamic-pricing) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by acowebs (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Remote code execution (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/aco-woo-dynamic-pricing (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/aco-woo-dynamic-pricing"><img src="https://laskyr.com/plugins/aco-woo-dynamic-pricing/badge.svg" alt="Dynamic Pricing With Discount Rules for WooCom… vulnerability status"></a>