Skip to content
Laskyr

CVE-2026-92798: User Registration & Membership remote code execution vulnerability

high 8.1 published 2026-10-17 · updated 2026-10-19

Fixed in User Registration & Membership 5.3.0 (first release after the affected range)

User Registration & Membership 5.2.8 and older is affected by this remote code execution issue. Sites on 5.3.0 or newer are not affected; the latest release is 5.3.1.

Affected versions
5.2.8 and older
Fixed in
5.3.0 *
Latest version
5.3.1
Severity
High · CVSS 8.1
Active installs
50,000+
Type
Remote code execution

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

What to do now

  1. Update User Registration & Membership to 5.3.0 or newer (the latest is 5.3.1): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known User Registration & Membership issue. With WP-CLI: wp plugin get user-registration --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The User Registration & Membership plugin for WordPress is vulnerable to Arbitrary Shortcode Execution in versions up to, and including, 5.2.8 This is due to insufficient input sanitization in the 'referrer_url' branch of UR_Smart_Tags::process(), where the attacker-controlled HTTP_REFERER header is only passed through sanitize_text_field() — which does not strip WordPress shortcode delimiters — before being substituted into a Content Restriction message that is subsequently executed via apply_shortcodes()/do_shortcode(). This makes it possible for unauthenticated attackers to execute arbitrary registered shortcodes on any restricted page whose message uses the supported {{referrer_url}} smart tag.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-92798.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit