Skip to content
Laskyr

CVE-2026-86787: affiliate-toolkit remote code execution vulnerability

high 7.2 published 2026-10-14

Fixed in affiliate-toolkit 3.9.1

affiliate-toolkit 3.8.7 up to (not including) 3.9.1 is affected by this remote code execution issue. Sites on 3.9.1 or newer are not affected; the latest release is 3.9.3.

Affected versions
3.8.7 up to (not including) 3.9.1
Fixed in
3.9.1
Latest version
3.9.3
Severity
High · CVSS 7.2
Active installs
2,000+
Type
Remote code execution

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update affiliate-toolkit to 3.9.1 or newer (the latest is 3.9.3): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known affiliate-toolkit issue. With WP-CLI: wp plugin get affiliate-toolkit-starter --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The affiliate-toolkit WordPress plugin before 3.9.1 does not prevent a low-privileged user from supplying a template body that its bundled templating engine compiles and executes as PHP, allowing users with the Contributor role or above to run arbitrary PHP code on the server.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-86787.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit