CVE-2026-81344: ACF Frontend Admin by DynamiApps remote code execution vulnerability
medium 6.6 published 2026-10-17 · updated 2026-10-19
- Affected versions
- 3.29.13 and older
- Fixed in
- 3.30.0 *
- Latest version
- 3.30.2
- Severity
- Medium · CVSS 6.6
- Active installs
- 8,000+
- Type
- Remote code execution
* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.
What an attacker needs
- Access: An admin-level account (per the CVSS score).
CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
What to do now
- Update ACF Frontend Admin by DynamiApps to 3.30.0 or newer (the latest is 3.30.2): Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- Not sure which version you run? Check your version against every known ACF Frontend Admin by DynamiApps issue.
With WP-CLI:
wp plugin get acf-frontend-form-element --field=version. - If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.
The advisory
The ACF Frontend Admin by DynamiApps WordPress plugin through 3.29.13 does not restrict which PHP classes may be instantiated when it deserialises stored post content that is rendered on public-facing pages, allowing high-privilege users such as administrators to inject a PHP object which, given a suitable POP chain in another installed ACF Frontend Admin by DynamiApps WordPress plugin through 3.29.13 or in WordPress core, can be leveraged to achieve remote code execution.
References
- NVD CVE-2026-81344 nvd.nist.gov
- WPScan advisory wpscan.com
Related
Ran an affected version? Check your site for signs of a hack
The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.
Where this data comes from
- CVE record, score and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Versions and install counts: wordpress.org/plugins/acf-frontend-form-element (Plugins API), fetched 2026-11-04.
- The summary, “what an attacker needs” and “what to do” sections are our plain-English reading of the record and the plugin's release history; the quoted description is the record's own text. Spot an error? Email Daniel.