Skip to content
Laskyr

dompdf/dompdf security advisory

CVE-2026-59942: Dompdf: Denial of Service (DoS) via Resource Exhaustion using Oversized Image Bitmaps

CVE-2026-59942 is a medium-severity denial of service vulnerability in the PHP package dompdf/dompdf (CVSS 7.5), published 28 July 2026. It is fixed in 3.1.6; earlier versions are affected. It can be exploited without an account.

medium 7.5 published 2026-07-28 · updated 2026-08-04

Fixed in dompdf/dompdf 3.1.6

This denial of service issue affects dompdf/dompdf versions < 3.1.6. Upgrade to the fixed version for your release line (3.1.6). The newest release, 3.1.6, is not affected.

Affected versions
< 3.1.6
Fixed in
3.1.6
Newest release
3.1.6
Severity
Medium · CVSS 7.5
Type
Denial of service
CWE-400
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your dompdf/dompdf version affected?

Run composer show dompdf/dompdf in your project, then enter the version. We check it against this and every other known dompdf/dompdf advisory.

Who can exploit CVE-2026-59942

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Your app is only exposed if it uses the affected part of dompdf/dompdf. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-59942 in dompdf/dompdf

  1. Find the installed version: composer show dompdf/dompdf. If you never required it yourself, composer why dompdf/dompdf shows which package pulls it in.
  2. Update it: composer update dompdf/dompdf --with-all-dependencies. You need 3.1.6 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "dompdf/dompdf": "^3.1.6" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-59942.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for denial of service issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-59942 advisory

Dompdf is an HTML to PDF converter for PHP. Versions 3.15 and prior are vulnerable to a Denial of Service (DoS) attack via resource exhaustion. An attacker can crash the PHP process by providing a specially crafted HTML document containing a single image with massive dimensions (e.g., 30,000x30,000 pixels). While Dompdf implements internal checks to validate image dimensions, these can be bypassed by using a high-entropy image (such as random noise) encoded in Base64 and wrapped in specific CSS containers. The vulnerability exists because the dimension validation happens early, but the resource allocation for calculating the object's bounding box and internal buffers during the rendering phase does not strictly limit the cumulative CPU time or memory usage for a single object that has passed the initial check. An unauthenticated remote attacker can cause a complete Denial of Service on the web server by submitting a crafted HTML string. This affects any application that allows users to provide HTML content or URLs that are subsequently converted to PDF using Dompdf. This issue has been fixed in version 3.16.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-59942. Advisory title: “Dompdf: Denial of Service (DoS) via Resource Exhaustion using Oversized Image Bitmaps”.

References

Other dompdf/dompdf advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit